summaryrefslogtreecommitdiffstats
path: root/scripts/package/debian
diff options
context:
space:
mode:
authorMasahiro Yamada <masahiroy@kernel.org>2023-08-01 21:19:26 +0900
committerMasahiro Yamada <masahiroy@kernel.org>2023-08-08 01:08:54 +0900
commitd9287ea8ffc9be2ab4c81c32e1ca54478425ba38 (patch)
tree8f5070cc4659590ae96b133593ca1fd3df5820c5 /scripts/package/debian
parent4b970e436523ed34da4ced74ad2b81e5a4f573f2 (diff)
downloadlinux-d9287ea8ffc9be2ab4c81c32e1ca54478425ba38.tar.gz
linux-d9287ea8ffc9be2ab4c81c32e1ca54478425ba38.tar.bz2
linux-d9287ea8ffc9be2ab4c81c32e1ca54478425ba38.zip
kbuild: deb-pkg: split debian/rules
debian/rules is generated by shell, but the escape sequence (\$) is unreadable. debian/rules embeds only two variables (ARCH and KERNELRELEASE). Split them out to debian/rules.vars, and check-in the rest of Makefile code to scripts/package/debian/rules. Signed-off-by: Masahiro Yamada <masahiroy@kernel.org> Tested-by: Nathan Chancellor <nathan@kernel.org> Reviewed-by: Nicolas Schier <nicolas@fjasle.eu>
Diffstat (limited to 'scripts/package/debian')
-rwxr-xr-xscripts/package/debian/rules28
1 files changed, 28 insertions, 0 deletions
diff --git a/scripts/package/debian/rules b/scripts/package/debian/rules
new file mode 100755
index 000000000000..226e127efd63
--- /dev/null
+++ b/scripts/package/debian/rules
@@ -0,0 +1,28 @@
+#!/usr/bin/make -f
+# SPDX-License-Identifier: GPL-2.0-only
+
+include debian/rules.vars
+
+srctree ?= .
+
+.PHONY: binary binary-indep binary-arch
+binary: binary-arch binary-indep
+binary-indep: build-indep
+binary-arch: build-arch
+ $(MAKE) -f $(srctree)/Makefile ARCH=$(ARCH) \
+ KERNELRELEASE=$(KERNELRELEASE) \
+ run-command KBUILD_RUN_COMMAND=+$(srctree)/scripts/package/builddeb
+
+.PHONY: build build-indep build-arch
+build: build-arch build-indep
+build-indep:
+build-arch:
+ $(MAKE) -f $(srctree)/Makefile ARCH=$(ARCH) \
+ KERNELRELEASE=$(KERNELRELEASE) \
+ $(shell $(srctree)/scripts/package/deb-build-option) \
+ olddefconfig all
+
+.PHONY: clean
+clean:
+ rm -rf debian/files debian/linux-*
+ $(MAKE) -f $(srctree)/Makefile ARCH=$(ARCH) clean