summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2024-05-22 11:56:45 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2024-05-22 11:56:45 +0200
commit01048c7456785bc4a45452c84d8f31635e1fa60b (patch)
treee2b1c7b7ce75c8c5ba6e5de7673b76ae4009d7c6
parent46bcbe42236bbe058eaeb89a0d1a4f22926cfdf9 (diff)
downloadopenwrt-01048c7456785bc4a45452c84d8f31635e1fa60b.tar.gz
openwrt-01048c7456785bc4a45452c84d8f31635e1fa60b.tar.bz2
openwrt-01048c7456785bc4a45452c84d8f31635e1fa60b.zip
tools/padjffs2: use Host/Prepare/Default instead of raw commands
Now that Host/Prepare/Default is always defined, we can use that instead of using raw commands to move files from the src directory to HOST_BUILD_DIR. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
-rw-r--r--tools/padjffs2/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/tools/padjffs2/Makefile b/tools/padjffs2/Makefile
index 422d14db30..b893fadce5 100644
--- a/tools/padjffs2/Makefile
+++ b/tools/padjffs2/Makefile
@@ -13,8 +13,7 @@ PKG_RELEASE:=1
include $(INCLUDE_DIR)/host-build.mk
define Host/Prepare
- mkdir -p $(HOST_BUILD_DIR)
- $(CP) ./src/* $(HOST_BUILD_DIR)/
+ $(call Host/Prepare/Default)
find $(HOST_BUILD_DIR) -name .svn | $(XARGS) rm -rf
endef