summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWojciech Dubowik <Wojciech.Dubowik@westermo.com>2022-09-14 12:13:10 +0200
committerPetr Štetiar <ynezz@true.cz>2022-09-14 16:45:06 +0200
commit016c9344824c06f54412f23fa5962156edfc0d39 (patch)
treec399a09a0e45f7e7723e88ee78f4870cd190ee6b
parent00643b4584e73949de05ca8c3276a05657ba0d45 (diff)
downloadopenwrt-016c9344824c06f54412f23fa5962156edfc0d39.tar.gz
openwrt-016c9344824c06f54412f23fa5962156edfc0d39.tar.bz2
openwrt-016c9344824c06f54412f23fa5962156edfc0d39.zip
mpc85xx: Add 5.15 kernel as testing and fix configs
Build system: x86_64 Build-tested: generic Run-tested: generic/TL-WDR4900 v1 board from TP-Link Signed-off-by: Wojciech Dubowik <Wojciech.Dubowik@westermo.com> Signed-off-by: Petr Štetiar <ynezz@true.cz> [un-dmarc]
-rw-r--r--target/linux/mpc85xx/Makefile1
-rw-r--r--target/linux/mpc85xx/config-5.153
-rw-r--r--target/linux/mpc85xx/p1020/config-default1
-rw-r--r--target/linux/mpc85xx/p2020/config-default1
4 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
index 398e578882..f5f5a9c5c1 100644
--- a/target/linux/mpc85xx/Makefile
+++ b/target/linux/mpc85xx/Makefile
@@ -12,6 +12,7 @@ FEATURES:=squashfs ramdisk nand
SUBTARGETS:=p1010 p1020 p2020
KERNEL_PATCHVER:=5.10
+KERNEL_TESTING_PATCHVER:=5.15
KERNELNAME:=zImage
diff --git a/target/linux/mpc85xx/config-5.15 b/target/linux/mpc85xx/config-5.15
index 532d176c15..4f27d3bd70 100644
--- a/target/linux/mpc85xx/config-5.15
+++ b/target/linux/mpc85xx/config-5.15
@@ -57,6 +57,7 @@ CONFIG_DNOTIFY=y
CONFIG_DTC=y
# CONFIG_E200 is not set
CONFIG_E500=y
+CONFIG_E500_CPU=y
# CONFIG_E5500_CPU is not set
# CONFIG_E6500_CPU is not set
CONFIG_EARLY_PRINTK=y
@@ -194,6 +195,7 @@ CONFIG_PHYSICAL_START=0x00000000
CONFIG_PPC=y
CONFIG_PPC32=y
# CONFIG_PPC64 is not set
+# CONFIG_PPC_BOOK3S_32 is not set
CONFIG_PPC_85xx=y
# CONFIG_PPC_8xx is not set
CONFIG_PPC_ADV_DEBUG_DACS=2
@@ -254,6 +256,7 @@ CONFIG_THREAD_SHIFT=13
CONFIG_TICK_CPU_ACCOUNTING=y
CONFIG_TINY_SRCU=y
# CONFIG_TL_WDR4900_V1 is not set
+# CONFIG_TOOLCHAIN_DEFAULT_CPU is not set
# CONFIG_TQM8540 is not set
# CONFIG_TQM8541 is not set
# CONFIG_TQM8548 is not set
diff --git a/target/linux/mpc85xx/p1020/config-default b/target/linux/mpc85xx/p1020/config-default
index 6f2a9d2c3b..73176a87dc 100644
--- a/target/linux/mpc85xx/p1020/config-default
+++ b/target/linux/mpc85xx/p1020/config-default
@@ -34,6 +34,7 @@ CONFIG_MUTEX_SPIN_ON_OWNER=y
CONFIG_NET_FLOW_LIMIT=y
CONFIG_NR_CPUS=2
CONFIG_PADATA=y
+# CONFIG_PPC_QUEUED_SPINLOCKS is not set
CONFIG_REGMAP_IRQ=y
CONFIG_REGULATOR=y
CONFIG_RFS_ACCEL=y
diff --git a/target/linux/mpc85xx/p2020/config-default b/target/linux/mpc85xx/p2020/config-default
index e4ed758d95..1d9ef14276 100644
--- a/target/linux/mpc85xx/p2020/config-default
+++ b/target/linux/mpc85xx/p2020/config-default
@@ -19,6 +19,7 @@ CONFIG_NR_CPUS=2
CONFIG_PADATA=y
CONFIG_PCI_MSI=y
CONFIG_PPC_MSI_BITMAP=y
+# CONFIG_PPC_QUEUED_SPINLOCKS is not set
CONFIG_RFS_ACCEL=y
CONFIG_RPS=y
CONFIG_RTC_DRV_DS1307=y