summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2021-02-20 01:36:06 +0100
committerDavid Bauer <mail@david-bauer.net>2021-02-22 00:56:16 +0100
commit08826595fc6830d4e218179255eca37882279954 (patch)
tree81df486274c050af0291f5502d31062dd1574673
parent81b44a36264f5a50605c0d5f41d6eb838af4cb75 (diff)
downloadopenwrt-08826595fc6830d4e218179255eca37882279954.tar.gz
openwrt-08826595fc6830d4e218179255eca37882279954.tar.bz2
openwrt-08826595fc6830d4e218179255eca37882279954.zip
mpc85xx: add testing kernel for p1020
CONFIG_REGULATOR is required for the p1020 subtarget, as the AT803X driver depends on it. Signed-off-by: David Bauer <mail@david-bauer.net>
-rw-r--r--target/linux/mpc85xx/p1020/config-default2
-rw-r--r--target/linux/mpc85xx/p1020/target.mk2
2 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/p1020/config-default b/target/linux/mpc85xx/p1020/config-default
index c4c102ca45..28e9138241 100644
--- a/target/linux/mpc85xx/p1020/config-default
+++ b/target/linux/mpc85xx/p1020/config-default
@@ -31,8 +31,10 @@ CONFIG_MUTEX_SPIN_ON_OWNER=y
CONFIG_NET_FLOW_LIMIT=y
CONFIG_NR_CPUS=2
CONFIG_PADATA=y
+# CONFIG_PPC_QUEUED_SPINLOCKS is not set
CONFIG_RCU_STALL_COMMON=y
CONFIG_REGMAP_IRQ=y
+CONFIG_REGULATOR=y
CONFIG_RFS_ACCEL=y
CONFIG_RPS=y
# CONFIG_RTC_DRV_MAX77686 is not set
diff --git a/target/linux/mpc85xx/p1020/target.mk b/target/linux/mpc85xx/p1020/target.mk
index a25409eebb..2c7f3b42f2 100644
--- a/target/linux/mpc85xx/p1020/target.mk
+++ b/target/linux/mpc85xx/p1020/target.mk
@@ -1,6 +1,8 @@
BOARDNAME:=P1020
FEATURES+=nand
+KERNEL_TESTING_PATCHVER:=5.10
+
define Target/Description
Build firmware images for Freescale P1020 based boards.
endef