summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2024-11-19 13:12:28 +0100
committerRobert Marko <robimarko@gmail.com>2024-11-19 19:52:03 +0100
commit0d0a5eb4b590f6f1f50040a56a35179886b40e62 (patch)
tree8fb8e1b66d10ea72c350d25cfbcb1aee08e7b4b5
parent8ec35a2a1533ccff8a4b0e6f4f0a0954d1bee6a6 (diff)
downloadopenwrt-0d0a5eb4b590f6f1f50040a56a35179886b40e62.tar.gz
openwrt-0d0a5eb4b590f6f1f50040a56a35179886b40e62.tar.bz2
openwrt-0d0a5eb4b590f6f1f50040a56a35179886b40e62.zip
include/package-pack: translate PKGARCH for APK
We have a lot of script-only packages that are universal for all arch-s and those set PKGARCH:=all to indicate it. Unfortunately, APK expects architecture to be set to "noarch" instead to indicate that its universal so instead of having to update all packages that set PKGARCH:=all and thus break OPKG lets simply translate "all" to "noarch" when generating the APK package. This will be required as soon we update APK to include [1] as it will start enforcing package architecture checks. [1] https://gitlab.alpinelinux.org/alpine/apk-tools/-/commit/c1a3e69f24e235fc78f4dddb1f85fdf281464446 Suggested-by: Jonas Gorski <jonas.gorski@gmail.com> Link: https://github.com/openwrt/openwrt/pull/17015 Signed-off-by: Robert Marko <robimarko@gmail.com>
-rw-r--r--include/package-pack.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-pack.mk b/include/package-pack.mk
index e9892f9ca6..3ac7a036f9 100644
--- a/include/package-pack.mk
+++ b/include/package-pack.mk
@@ -344,7 +344,7 @@ else
--info "name:$(1)$$(ABIV_$(1))" \
--info "version:$(VERSION)" \
--info "description:$$(call description_escape,$$(strip $$(Package/$(1)/description)))" \
- --info "arch:$(PKGARCH)" \
+ $(if $(findstring all,$(PKGARCH)),--info "arch:noarch",--info "arch:$(PKGARCH)") \
--info "license:$(LICENSE)" \
--info "origin:$(SOURCE)" \
--info "url:$(URL)" \