summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2024-06-23 23:52:45 +0200
committerRobert Marko <robimarko@gmail.com>2024-06-25 17:57:07 +0200
commit10293403534b452133a4e1027622a5444da0a4be (patch)
tree10c266cdfcefcbbce182024c4bf651911c3aab1a
parente07cc3237e8069aa48a19b11415d00b2c2ddd014 (diff)
downloadopenwrt-10293403534b452133a4e1027622a5444da0a4be.tar.gz
openwrt-10293403534b452133a4e1027622a5444da0a4be.tar.bz2
openwrt-10293403534b452133a4e1027622a5444da0a4be.zip
tools: mtd-utils: fix disabling tests
Passing --disable-tests does not do anything since upstream commit [0] ("Fix test binary installation") as that commit removed it since there is already and existing --without-tests compile option to not compile the tests at all as --disable-tests was just disabling their installation. So, lets just pass --without-tests instead to disable test compilation. [0] https://git.infraroot.at/mtd-utils.git/commit/?id=7170a28d46d5db1e7a9da24a5555a194a233ef0b Fixes: 67efb6a66146 ("tools: mtd-utils: Update to version 2.1.4") Link: https://github.com/openwrt/openwrt/pull/15791 Signed-off-by: Robert Marko <robimarko@gmail.com>
-rw-r--r--tools/mtd-utils/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/mtd-utils/Makefile b/tools/mtd-utils/Makefile
index db96708906..f53dbdcc4e 100644
--- a/tools/mtd-utils/Makefile
+++ b/tools/mtd-utils/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mtd-utils
PKG_VERSION:=2.2.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://infraroot.at/pub/mtd/
@@ -33,7 +33,7 @@ HOST_CONFIGURE_VARS+= \
UUID_CFLAGS="-I$(STAGING_DIR_HOST)/include/e2fsprogs/uuid"
HOST_CONFIGURE_ARGS+= \
- --disable-tests \
+ --without-tests \
--without-crypto \
--without-xattr \
--without-zstd \