summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2024-03-30 15:33:58 +0900
committerHauke Mehrtens <hauke@hauke-m.de>2024-06-05 21:14:16 +0200
commit1fbfc251c9f4be33b9ac5cb4686af0a7edda7e05 (patch)
treef019bdca32f4eea7a82190af5e555fd2ecfe6b42
parentea8d140b25f2f197c49896a31b20a4af89b94c9d (diff)
downloadopenwrt-1fbfc251c9f4be33b9ac5cb4686af0a7edda7e05.tar.gz
openwrt-1fbfc251c9f4be33b9ac5cb4686af0a7edda7e05.tar.bz2
openwrt-1fbfc251c9f4be33b9ac5cb4686af0a7edda7e05.zip
ramips: add support for Buffalo WSR-2533DHPL2
Buffalo WSR-2533DHPL2 is a 2.4/5 GHz band 11ac (Wi-Fi 5) router, based on MediaTek MT7621A. Specification: - SoC : MediaTek MT7621AT - RAM : DDR3 128 MiB (Winbond W631GG6MB12J) - Flash : RAW-NAND 128 MiB (Winbond W29N01HVSINF) - WLAN : 2.4/5 GHz (2x MediaTek MT7615N) - Ethernet : 10/100/1000 Mbps x4 - Switch : MediaTek MT7530 (SoC) - LED/keys : 8x/6x (2x buttons, 1x slide-switch) - UART : through-hole on PCB (J4) - arrangement : 3.3V, GND, TX, RX from triangle-mark - settings : 57600n8 - Power : 12VDC 1.5A Flash instruction using factory.bin image: 1. boot WSR-2533DHPL2 normally with "Router" mode 2. access to the WebI ("http://192.168.11.1/") on the device and open firmware update page ("管理" -> "ファームウェア更新") 3. select the OpenWrt factory.bin image and click update ("更新実行") button Attention: do not use "factory-uboot.bin" image 4. Wait ~120 seconds to complete flashing Flash instruction using initramfs image: 1. prepare the TFTP server with the initramfs image renamed to "linux.trx-recovery" and IP address "192.168.11.2" 2. press the "AOSS" button while powering on the WSR-2533DHPL2 3. after 10 seconds, release the "AOSS" button, WSR-2533DHPL2 downloads the initramfs image and boot with it automatically 4. on the initramfs image, download the factory-uboot.bin image to the device and perform sysupgrade with it and "-F" option 5. wait ~120 seconds to complete flashing Notes: - There are 2x factory*.bin images for different purposes. - factory.bin : for flashing on OEM WebUI - factory-uboot.bin: for flashing on OEM bootloader or initramfs image factory-uboot.bin is useful for recoverying the device, or refreshing when the kernel partition is expanded in the future. sysupgrade on this device accepts factory-uboot.bin with option "-F", but on that situation, user configurations won't be kept, so it's not for normal use. MAC addresses: LAN : 18:EC:E7:xx:xx:E0 (board_data, "mac" (text)) WAN : 18:EC:E7:xx:xx:E0 (board_data, "mac" (text)) 2.4 GHz: 18:EC:E7:xx:xx:E1 (Factory, 0x4 (hex)) 5 GHz : 18:EC:E7:xx:xx:E4 (Factory, 0x8004 (hex)) Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
-rw-r--r--target/linux/ramips/dts/mt7621_buffalo_wsr-2533dhpl2.dts70
-rw-r--r--target/linux/ramips/image/mt7621.mk8
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/board.d/02_network2
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/uci-defaults/09_fix_crc3
-rw-r--r--target/linux/ramips/mt7621/base-files/lib/upgrade/buffalo.sh3
-rwxr-xr-xtarget/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh2
6 files changed, 88 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/mt7621_buffalo_wsr-2533dhpl2.dts b/target/linux/ramips/dts/mt7621_buffalo_wsr-2533dhpl2.dts
new file mode 100644
index 0000000000..d189a5ba09
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_buffalo_wsr-2533dhpl2.dts
@@ -0,0 +1,70 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621_buffalo_wsr-2533dhplx.dtsi"
+
+/ {
+ compatible = "buffalo,wsr-2533dhpl2", "mediatek,mt7621-soc";
+ model = "Buffalo WSR-2533DHPL2";
+
+ chosen {
+ bootargs = "console=ttyS0,57600n8 ubi.block=0,rootfs root=/dev/ubiblock0_0";
+ };
+};
+
+&nand {
+ status = "okay";
+
+ mediatek,bbt;
+ /*
+ * - u-boot - (kernel (6MiB, in "firmware"))
+ * - Kernel2 - board_data
+ */
+ mediatek,bmt-remap-range = <0x0 0x740000>,
+ <0x3e60000 0x4120000>;
+};
+
+&partitions {
+ partition@100000 {
+ label = "factory";
+ reg = <0x100000 0x40000>;
+ read-only;
+
+ nvmem-layout {
+ compatible = "fixed-layout";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ eeprom_factory_0: eeprom@0 {
+ reg = <0x0 0x4da8>;
+ };
+
+ eeprom_factory_8000: eeprom@8000 {
+ reg = <0x8000 0x4da8>;
+ };
+ };
+ };
+
+ partition@140000 {
+ compatible = "brcm,trx";
+ brcm,trx-magic = <0x324c4850>;
+ label = "firmware";
+ reg = <0x140000 0x3d20000>;
+ };
+
+ partition@3e60000 {
+ label = "Kernel2";
+ reg = <0x3e60000 0x3d20000>;
+ };
+
+ partition@7b80000 {
+ label = "glbcfg";
+ reg = <0x7b80000 0x200000>;
+ read-only;
+ };
+
+ partition@7d80000 {
+ label = "board_data";
+ reg = <0x7d80000 0x200000>;
+ read-only;
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 904fd11b1a..6827fdc1eb 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -563,6 +563,14 @@ define Device/buffalo_wsr-2533dhplx
sysupgrade-tar kernel=$$$$@ | append-metadata
endef
+define Device/buffalo_wsr-2533dhpl2
+ $(Device/buffalo_wsr-2533dhplx)
+ DEVICE_MODEL := WSR-2533DHPL2
+ BUFFALO_TRX_MAGIC := 0x324c4850
+ IMAGE_SIZE := 62592k
+endef
+TARGET_DEVICES += buffalo_wsr-2533dhpl2
+
define Device/buffalo_wsr-2533dhpls
$(Device/buffalo_wsr-2533dhplx)
DEVICE_MODEL := WSR-2533DHPLS
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
index 71a342f8f4..247a27d145 100644
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
@@ -11,6 +11,7 @@ ramips_setup_interfaces()
alfa-network,ax1800rm|\
ampedwireless,ally-r1900k|\
asus,rt-ax53u|\
+ buffalo,wsr-2533dhpl2|\
buffalo,wsr-2533dhpls|\
gehua,ghl-r-001|\
h3c,tx1800-plus|\
@@ -217,6 +218,7 @@ ramips_setup_macs()
lan_mac=$label_mac
;;
buffalo,wsr-1166dhp|\
+ buffalo,wsr-2533dhpl2|\
buffalo,wsr-2533dhpls)
wan_mac=$(mtd_get_mac_ascii board_data "mac")
lan_mac=$wan_mac
diff --git a/target/linux/ramips/mt7621/base-files/etc/uci-defaults/09_fix_crc b/target/linux/ramips/mt7621/base-files/etc/uci-defaults/09_fix_crc
index 89889bc1c2..80e6d71d90 100644
--- a/target/linux/ramips/mt7621/base-files/etc/uci-defaults/09_fix_crc
+++ b/target/linux/ramips/mt7621/base-files/etc/uci-defaults/09_fix_crc
@@ -13,6 +13,9 @@ fixup_trx_crc() {
}
case "$(board_name)" in
+buffalo,wsr-2533dhpl2)
+ fixup_trx_crc 0x50484c32
+ ;;
buffalo,wsr-2533dhpls)
fixup_trx_crc 0x44484C53
;;
diff --git a/target/linux/ramips/mt7621/base-files/lib/upgrade/buffalo.sh b/target/linux/ramips/mt7621/base-files/lib/upgrade/buffalo.sh
index 8040d4c768..5d3e184d08 100644
--- a/target/linux/ramips/mt7621/base-files/lib/upgrade/buffalo.sh
+++ b/target/linux/ramips/mt7621/base-files/lib/upgrade/buffalo.sh
@@ -17,6 +17,9 @@
# TRX magic numbers of each model
case "$(board_name)" in
+buffalo,wsr-2533dhpl2)
+ BUFFALO_TRX_MAGIC="50484c32" # "PHL2"
+ ;;
buffalo,wsr-2533dhpls)
BUFFALO_TRX_MAGIC="44484c53" # "DHLS"
;;
diff --git a/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh b/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
index 82eda0bf2f..32dad72944 100755
--- a/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
@@ -15,6 +15,7 @@ platform_check_image() {
[ "$#" -gt 1 ] && return 1
case "$board" in
+ buffalo,wsr-2533dhpl2|\
buffalo,wsr-2533dhpls)
buffalo_check_image "$board" "$magic" "$1" || return 1
;;
@@ -143,6 +144,7 @@ platform_do_upgrade() {
zyxel,nwa55axe)
nand_do_upgrade "$1"
;;
+ buffalo,wsr-2533dhpl2|\
buffalo,wsr-2533dhpls)
buffalo_do_upgrade "$1"
;;