diff options
author | Rosen Penev <rosenp@gmail.com> | 2022-08-20 14:12:32 -0700 |
---|---|---|
committer | Christian Marangi <ansuelsmth@gmail.com> | 2022-09-10 15:42:36 +0200 |
commit | 22b7bd6b1355baf7220136b6bd8277a321b70c39 (patch) | |
tree | 5be900833adbd4d1b0ef2449c5b28e6dabb7eca2 | |
parent | d02e887d7ceb25008fa70c42174207dfeb65b5f0 (diff) | |
download | openwrt-22b7bd6b1355baf7220136b6bd8277a321b70c39.tar.gz openwrt-22b7bd6b1355baf7220136b6bd8277a321b70c39.tar.bz2 openwrt-22b7bd6b1355baf7220136b6bd8277a321b70c39.zip |
Makefile: replace head call with grep's -m
head is not necessary here.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r-- | Makefile | 2 | ||||
-rw-r--r-- | target/sdk/files/Makefile | 2 |
2 files changed, 2 insertions, 2 deletions
@@ -14,7 +14,7 @@ $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt dir world: -DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep -E '\/usr' | head -n 1) +DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep -E '\/usr' -m 1) export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH) ifneq ($(OPENWRT_BUILD),1) diff --git a/target/sdk/files/Makefile b/target/sdk/files/Makefile index a710ca5f51..f620f0ef01 100644 --- a/target/sdk/files/Makefile +++ b/target/sdk/files/Makefile @@ -14,7 +14,7 @@ export TOPDIR LC_ALL LANG SDK world: -DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep -E '\/usr' | head -n 1) +DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep -E '\/usr' -m 1) export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH) ifneq ($(OPENWRT_BUILD),1) |