summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2024-05-03 14:46:33 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2024-05-03 14:53:11 +0200
commit23de46c913912cf8695328e966bc47cc57a6e09f (patch)
tree8455ee9b8a24985d3651701177cddc63d3d59588
parent0d436fc8b10fe5d902034cf60885696da7ee0002 (diff)
downloadopenwrt-23de46c913912cf8695328e966bc47cc57a6e09f.tar.gz
openwrt-23de46c913912cf8695328e966bc47cc57a6e09f.tar.bz2
openwrt-23de46c913912cf8695328e966bc47cc57a6e09f.zip
xdp-tools: fix wrong matching for OPENWRT_VERBOSE
To enable verbose log for xdp-tools compilation, we check for "c" in the OPENWRT_VERBOSE, but verbose.mk supports only "w" and "s" for V=1 and V=99. Fix the wrong matching and correctly enable verbose output matching for "s". Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
-rw-r--r--package/network/utils/xdp-tools/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/utils/xdp-tools/Makefile b/package/network/utils/xdp-tools/Makefile
index 8484ca758b..8a839954e9 100644
--- a/package/network/utils/xdp-tools/Makefile
+++ b/package/network/utils/xdp-tools/Makefile
@@ -89,7 +89,7 @@ CONFIGURE_VARS += \
LLC="$(LLVM_LLC)" \
BPF_LDFLAGS="-march=$(BPF_TARGET) -mcpu=v3"
-ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
+ifneq ($(findstring s,$(OPENWRT_VERBOSE)),)
MAKE_FLAGS+=V=1
endif