summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Harvey <tharvey@gateworks.com>2020-05-28 08:04:42 -0700
committerPetr Štetiar <ynezz@true.cz>2020-06-03 16:49:28 +0200
commit25641709d87d710c13bd558d681713ae1a5f11b1 (patch)
tree04c34d555729b9200c353278dcf44f606fe58b0a
parent41cab5029b66f3e58683689fc79d90374e01e741 (diff)
downloadopenwrt-25641709d87d710c13bd558d681713ae1a5f11b1.tar.gz
openwrt-25641709d87d710c13bd558d681713ae1a5f11b1.tar.bz2
openwrt-25641709d87d710c13bd558d681713ae1a5f11b1.zip
kernel: iio: add drivers for st_lsm6dsx IMU MEMS sensors
Add kmod for the ST LSM6DSX IMU driver. Signed-off-by: Tim Harvey <tharvey@gateworks.com> [fixed missing regmap module dependencies] Signed-off-by: Petr Štetiar <ynezz@true.cz>
-rw-r--r--package/kernel/linux/modules/iio.mk48
1 files changed, 48 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/iio.mk b/package/kernel/linux/modules/iio.mk
index b52ec8c8cd..ab14e97a05 100644
--- a/package/kernel/linux/modules/iio.mk
+++ b/package/kernel/linux/modules/iio.mk
@@ -364,6 +364,54 @@ endef
$(eval $(call KernelPackage,iio-st_accel-spi))
+define KernelPackage/iio-lsm6dsx
+ SUBMENU:=$(IIO_MENU)
+ DEPENDS:=+kmod-iio-core +kmod-iio-kfifo-buf +kmod-regmap-core
+ TITLE:=ST LSM6DSx driver for IMU MEMS sensors
+ KCONFIG:=CONFIG_IIO_ST_LSM6DSX
+ FILES:=$(LINUX_DIR)/drivers/iio/imu/st_lsm6dsx/st_lsm6dsx.ko
+ AUTOLOAD:=$(call AutoProbe,st_lsm6dsx)
+endef
+
+define KernelPackage/iio-lsm6dsx/description
+ Support for the ST LSM6DSx and related IMU MEMS sensors.
+endef
+
+$(eval $(call KernelPackage,iio-lsm6dsx))
+
+
+define KernelPackage/iio-lsm6dsx-i2c
+ SUBMENU:=$(IIO_MENU)
+ DEPENDS:=+kmod-iio-lsm6dsx +kmod-i2c-core +kmod-regmap-i2c
+ TITLE:=ST LSM6DSx driver for IMU MEMS sensors (I2C)
+ KCONFIG:=CONFIG_IIO_ST_LSM6DSX
+ FILES:=$(LINUX_DIR)/drivers/iio/imu/st_lsm6dsx/st_lsm6dsx_i2c.ko
+ AUTOLOAD:=$(call AutoProbe,st_lsm6dsx-i2c)
+endef
+
+define KernelPackage/iio-lsm6dsx-i2c/description
+ Support for the ST LSM6DSx and related IMU MEMS I2C sensors.
+endef
+
+$(eval $(call KernelPackage,iio-lsm6dsx-i2c))
+
+
+define KernelPackage/iio-lsm6dsx-spi
+ SUBMENU:=$(IIO_MENU)
+ DEPENDS:=+kmod-iio-lsm6dsx +kmod-regmap-spi
+ TITLE:=ST LSM6DSx driver for IMU MEMS sensors (SPI)
+ KCONFIG:=CONFIG_IIO_ST_LSM6DSX
+ FILES:=$(LINUX_DIR)/drivers/iio/imu/st_lsm6dsx/st_lsm6dsx_spi.ko
+ AUTOLOAD:=$(call AutoProbe,st_lsm6dsx-spi)
+endef
+
+define KernelPackage/iio-lsm6dsx-spi/description
+ Support for the ST LSM6DSx and related IMU MEMS SPI sensors.
+endef
+
+$(eval $(call KernelPackage,iio-lsm6dsx-spi))
+
+
define KernelPackage/iio-sps30
SUBMENU:=$(IIO_MENU)
DEPENDS:=@!LINUX_4_14 +kmod-i2c-core +kmod-iio-core +kmod-industrialio-triggered-buffer +kmod-lib-crc8