summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2023-04-20 01:59:32 -0700
committerChristian Marangi <ansuelsmth@gmail.com>2023-04-20 14:21:46 +0200
commit291b137778eece9edf4b960d4d5c27fc1ce91e06 (patch)
tree35ceb4b3bce85a573fd280a5a8eb5d8d63527afc
parent42eeb22450f2c3225fa79a75c0ba881ac6809a77 (diff)
downloadopenwrt-291b137778eece9edf4b960d4d5c27fc1ce91e06.tar.gz
openwrt-291b137778eece9edf4b960d4d5c27fc1ce91e06.tar.bz2
openwrt-291b137778eece9edf4b960d4d5c27fc1ce91e06.zip
tools/lz4: build with meson
Simplifies Makefile and speeds up compilation. Before: Executed in 68.00 secs fish external usr time 104.17 secs 1.33 millis 104.17 secs sys time 4.29 secs 0.35 millis 4.29 secs After: Executed in 27.98 secs fish external usr time 25.18 secs 1.32 millis 25.18 secs sys time 3.31 secs 0.35 millis 3.31 secs Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--tools/Makefile1
-rw-r--r--tools/lz4/Makefile34
2 files changed, 12 insertions, 23 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 722d42b2c2..7e8fbad107 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -104,6 +104,7 @@ $(curdir)/isl/compile := $(curdir)/gmp/compile
$(curdir)/liblzo/compile := $(curdir)/cmake/compile
$(curdir)/libressl/compile := $(curdir)/pkgconf/compile
$(curdir)/libtool/compile := $(curdir)/automake/compile $(curdir)/missing-macros/compile
+$(curdir)/lz4/compile := $(curdir)/meson/compile
$(curdir)/lzma-old/compile := $(curdir)/zlib/compile
$(curdir)/lzop/compile := $(curdir)/cmake/compile $(curdir)/liblzo/compile
$(curdir)/llvm-bpf/compile := $(curdir)/cmake/compile
diff --git a/tools/lz4/Makefile b/tools/lz4/Makefile
index c5d4f6f16b..8f12ca93e6 100644
--- a/tools/lz4/Makefile
+++ b/tools/lz4/Makefile
@@ -17,33 +17,21 @@ PKG_HASH:=0b0e3aa07c8c063ddf40b082bdf7e37a1562bda40a0ff5272957f3e987e0e54b
PKG_LICENSE:=BSD-2-Clause
PKG_LICENSE_FILES:=LICENSE lib/LICENSE
-HOST_BUILD_PARALLEL:=1
-
include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/meson.mk
+
+MESON_HOST_BUILD_DIR:=$(HOST_BUILD_DIR)/contrib/meson/openwrt-build
# Always optimize for speed
HOST_CFLAGS := $(filter-out -O%,$(HOST_CFLAGS)) -O3
-HOST_MAKE_FLAGS+=PREFIX=$(HOST_BUILD_PREFIX) \
- ENABLE_DOCS=1
-
-define Host/Configure
-endef
-
-define Host/Compile
- $(call Host/Compile/Default,default)
-endef
-
-define Host/Install
- $(call Host/Compile/Default,install)
-endef
-
-define Host/Uninstall
- $(call Host/Compile/Default,uninstall)
- $(call Host/Compile/Default,clean)
-endef
-
-define Host/Clean
-endef
+MESON_HOST_ARGS += \
+ -Ddefault_library=static \
+ -Ddebug-level=0 \
+ -Dunstable=false \
+ -Dprograms=true \
+ -Dtests=false \
+ -Dcontrib=false \
+ -Dexamples=false
$(eval $(call HostBuild))