summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2023-03-06 11:58:56 -0300
committerHauke Mehrtens <hauke@hauke-m.de>2023-04-02 22:07:28 +0200
commit2faa7ff09e0970e8d5f6bf5906dd4e8c987ec970 (patch)
tree308bf918ad4390f86ee6951ece84afc4900916cc
parent0636d6b925ad25aa155b411a54921b03c97a9349 (diff)
downloadopenwrt-2faa7ff09e0970e8d5f6bf5906dd4e8c987ec970.tar.gz
openwrt-2faa7ff09e0970e8d5f6bf5906dd4e8c987ec970.tar.bz2
openwrt-2faa7ff09e0970e8d5f6bf5906dd4e8c987ec970.zip
openssl: fix variable reference in conffiles
Fix the trivial abscence of $() when assigning engine config files to the main libopenssl-config package even if the corresponding engines were not built into the main library. This is mostly cosmetic, since scripts/ipkg-build tests the file's presence before it is actually included in the package's conffiles. Fixes: 30b0351039 "openssl: configure engine packages during install" Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com> (cherry picked from commit c75cd5f6028da6ceb1fb3438da93e2305cd720b1)
-rw-r--r--package/libs/openssl/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index f27e86b3a1..3b287b3be6 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -11,7 +11,7 @@ PKG_NAME:=openssl
PKG_BASE:=1.1.1
PKG_BUGFIX:=t
PKG_VERSION:=$(PKG_BASE)$(PKG_BUGFIX)
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_USE_MIPS16:=0
PKG_BUILD_PARALLEL:=1
@@ -128,8 +128,8 @@ endef
define Package/libopenssl-conf/conffiles
/etc/ssl/openssl.cnf
-$(if CONFIG_OPENSSL_ENGINE_BUILTIN_DEVCRYPTO,/etc/ssl/engines.cnf.d/devcrypto.cnf)
-$(if CONFIG_OPENSSL_ENGINE_BUILTIN_PADLOCK,/etc/ssl/engines.cnf.d/padlock.cnf)
+$(if $(CONFIG_OPENSSL_ENGINE_BUILTIN_DEVCRYPTO),/etc/ssl/engines.cnf.d/devcrypto.cnf)
+$(if $(CONFIG_OPENSSL_ENGINE_BUILTIN_PADLOCK),/etc/ssl/engines.cnf.d/padlock.cnf)
endef
define Package/libopenssl-conf/description