summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2024-03-23 23:58:36 +0100
committerZoltan HERPAI <wigyori@uid0.hu>2024-04-19 18:42:05 +0200
commit30149ba1ae5cdb503c7a1024ba3ba56d77797f1c (patch)
tree2ea3f3b95b6b5aad9bc9dd24d7e8bbace67c5639
parent01fc454a0cd0ab140ae54e0e5a4698763b11d211 (diff)
downloadopenwrt-30149ba1ae5cdb503c7a1024ba3ba56d77797f1c.tar.gz
openwrt-30149ba1ae5cdb503c7a1024ba3ba56d77797f1c.tar.bz2
openwrt-30149ba1ae5cdb503c7a1024ba3ba56d77797f1c.zip
sunxi: move KERNEL_LOADADDR into subtargets
As preparation for the arm926ej-s support which has a different load address, move the KERNEL_LOADADDR into the subtargets. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
-rw-r--r--target/linux/sunxi/image/Makefile1
-rw-r--r--target/linux/sunxi/image/cortexa53.mk2
-rw-r--r--target/linux/sunxi/image/cortexa7.mk2
-rw-r--r--target/linux/sunxi/image/cortexa8.mk2
4 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index 738585accc..cc1c1ba42d 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -10,7 +10,6 @@ FAT32_BLOCK_SIZE=1024
FAT32_BLOCKS=$(shell echo $$(($(CONFIG_SUNXI_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
DEVICE_VARS := SUNXI_DTS SUNXI_DTS_DIR
-KERNEL_LOADADDR:=0x40008000
define Build/sunxi-sdcard
rm -f $@.boot
diff --git a/target/linux/sunxi/image/cortexa53.mk b/target/linux/sunxi/image/cortexa53.mk
index 63ada59f85..06b409deb7 100644
--- a/target/linux/sunxi/image/cortexa53.mk
+++ b/target/linux/sunxi/image/cortexa53.mk
@@ -3,6 +3,8 @@
# Copyright (C) 2013-2016 OpenWrt.org
# Copyright (C) 2016 Yousong Zhou
+KERNEL_LOADADDR:=0x40008000
+
define Device/sun50i
SUNXI_DTS_DIR := allwinner/
KERNEL_NAME := Image
diff --git a/target/linux/sunxi/image/cortexa7.mk b/target/linux/sunxi/image/cortexa7.mk
index 3191cec4fd..a85b20531d 100644
--- a/target/linux/sunxi/image/cortexa7.mk
+++ b/target/linux/sunxi/image/cortexa7.mk
@@ -3,6 +3,8 @@
# Copyright (C) 2013-2019 OpenWrt.org
# Copyright (C) 2016 Yousong Zhou
+KERNEL_LOADADDR:=0x40008000
+
define Device/cubietech_cubieboard2
DEVICE_VENDOR := Cubietech
DEVICE_MODEL := Cubieboard2
diff --git a/target/linux/sunxi/image/cortexa8.mk b/target/linux/sunxi/image/cortexa8.mk
index dd8a16763b..e27db1ee16 100644
--- a/target/linux/sunxi/image/cortexa8.mk
+++ b/target/linux/sunxi/image/cortexa8.mk
@@ -3,6 +3,8 @@
# Copyright (C) 2013-2016 OpenWrt.org
# Copyright (C) 2016 Yousong Zhou
+KERNEL_LOADADDR:=0x40008000
+
define Device/cubietech_a10-cubieboard
DEVICE_VENDOR := Cubietech
DEVICE_MODEL := Cubieboard