summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2017-11-07 09:45:50 +0100
committerFelix Fietkau <nbd@nbd.name>2017-12-08 19:41:18 +0100
commit34bbbbf9c3b39e7b2d81df590aad5cdbd00280d6 (patch)
treec732597a7f040e71187a701e0c2e56e82a223397
parent98fb380d8855f7d6b94f3be791331adaa3d88a2a (diff)
downloadopenwrt-34bbbbf9c3b39e7b2d81df590aad5cdbd00280d6.tar.gz
openwrt-34bbbbf9c3b39e7b2d81df590aad5cdbd00280d6.tar.bz2
openwrt-34bbbbf9c3b39e7b2d81df590aad5cdbd00280d6.zip
merge: base: update base-files and basic config
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
-rw-r--r--Config.in2
-rw-r--r--Makefile2
-rw-r--r--README6
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/bin/config_generate10
-rwxr-xr-xpackage/base-files/files/etc/init.d/system2
-rw-r--r--package/base-files/files/lib/preinit/10_indicate_preinit2
-rw-r--r--package/base-files/image-config.in8
-rwxr-xr-xscripts/checkpatch.pl2
-rw-r--r--scripts/config/mconf.c2
10 files changed, 19 insertions, 19 deletions
diff --git a/Config.in b/Config.in
index ddbc4e2ea4..d30c04839e 100644
--- a/Config.in
+++ b/Config.in
@@ -4,7 +4,7 @@
# See /LICENSE for more information.
#
-mainmenu "LEDE Configuration"
+mainmenu "OpenWrt Configuration"
config MODULES
option modules
diff --git a/Makefile b/Makefile
index 09db75c550..0a1f96a973 100644
--- a/Makefile
+++ b/Makefile
@@ -14,7 +14,7 @@ export TOPDIR LC_ALL LANG TZ
empty:=
space:= $(empty) $(empty)
-$(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the LEDE directory must not include any spaces))
+$(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt directory must not include any spaces))
world:
diff --git a/README b/README
index 405c18bac0..864ea2f1b9 100644
--- a/README
+++ b/README
@@ -1,4 +1,4 @@
-This is the buildsystem for the LEDE Linux distribution.
+This is the buildsystem for the OpenWrt Linux distribution.
Please use "make menuconfig" to choose your preferred
configuration for the toolchain and firmware.
@@ -23,7 +23,7 @@ the lack of case sensitiveness in the file system.
Sunshine!
- Your LEDE Community
- http://www.lede-project.org
+ Your OpenWrt Community
+ http://www.openwrt.org
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 077bed469d..5afb02db28 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -34,7 +34,7 @@ define Package/base-files
SECTION:=base
CATEGORY:=Base system
DEPENDS:=+netifd +libc +procd +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:lede-keyring +NAND_SUPPORT:ubi-utils +fstools +fwtool
- TITLE:=Base filesystem for Lede
+ TITLE:=Base filesystem for OpenWrt
URL:=http://openwrt.org/
VERSION:=$(PKG_RELEASE)-$(REVISION)
endef
diff --git a/package/base-files/files/bin/config_generate b/package/base-files/files/bin/config_generate
index a8311fc595..bbed567def 100755
--- a/package/base-files/files/bin/config_generate
+++ b/package/base-files/files/bin/config_generate
@@ -223,7 +223,7 @@ generate_static_system() {
uci -q batch <<-EOF
delete system.@system[0]
add system system
- set system.@system[-1].hostname='LEDE'
+ set system.@system[-1].hostname='OpenWrt'
set system.@system[-1].timezone='UTC'
set system.@system[-1].ttylogin='0'
set system.@system[-1].log_size='64'
@@ -233,10 +233,10 @@ generate_static_system() {
set system.ntp='timeserver'
set system.ntp.enabled='1'
set system.ntp.enable_server='0'
- add_list system.ntp.server='0.lede.pool.ntp.org'
- add_list system.ntp.server='1.lede.pool.ntp.org'
- add_list system.ntp.server='2.lede.pool.ntp.org'
- add_list system.ntp.server='3.lede.pool.ntp.org'
+ add_list system.ntp.server='0.openwrt.pool.ntp.org'
+ add_list system.ntp.server='1.openwrt.pool.ntp.org'
+ add_list system.ntp.server='2.openwrt.pool.ntp.org'
+ add_list system.ntp.server='3.openwrt.pool.ntp.org'
EOF
if json_is_a system object; then
diff --git a/package/base-files/files/etc/init.d/system b/package/base-files/files/etc/init.d/system
index 8c5f677299..531aa8cbc5 100755
--- a/package/base-files/files/etc/init.d/system
+++ b/package/base-files/files/etc/init.d/system
@@ -7,7 +7,7 @@ USE_PROCD=1
validate_system_section()
{
uci_validate_section system system "${1}" \
- 'hostname:string:lede' \
+ 'hostname:string:OpenWrt' \
'conloglevel:uinteger' \
'buffersize:uinteger' \
'timezone:string:UTC' \
diff --git a/package/base-files/files/lib/preinit/10_indicate_preinit b/package/base-files/files/lib/preinit/10_indicate_preinit
index 5442a749b1..c3ec7bfdf7 100644
--- a/package/base-files/files/lib/preinit/10_indicate_preinit
+++ b/package/base-files/files/lib/preinit/10_indicate_preinit
@@ -113,7 +113,7 @@ preinit_ip() {
preinit_config_board
fi
- preinit_net_echo "Doing Lede Preinit\n"
+ preinit_net_echo "Doing OpenWrt Preinit\n"
}
preinit_ip_deconfig() {
diff --git a/package/base-files/image-config.in b/package/base-files/image-config.in
index 87d2ac6c54..88ec50a8e8 100644
--- a/package/base-files/image-config.in
+++ b/package/base-files/image-config.in
@@ -158,7 +158,7 @@ if VERSIONOPT
config VERSION_DIST
string
prompt "Release distribution"
- default "LEDE"
+ default "OpenWrt"
help
This is the name of the release distribution.
If unspecified, it defaults to OpenWrt.
@@ -201,13 +201,13 @@ if VERSIONOPT
%c .. Configured release revision code or value of %R, lowercase
%N .. Release name, uppercase
%n .. Release name, lowercase
- %D .. Distribution name or "Lede", uppercase
- %d .. Distribution name or "lede", lowercase
+ %D .. Distribution name or "OpenWrt", uppercase
+ %d .. Distribution name or "openwrt", lowercase
%T .. Target name
%S .. Target/Subtarget name
%A .. Package architecture
%t .. Build taint flags, e.g. "no-all busybox"
- %M .. Manufacturer name or "Lede"
+ %M .. Manufacturer name or "OpenWrt"
%P .. Product name or "Generic"
%h .. Hardware revision or "v0"
diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
index 05fd772c91..5224ea49c3 100755
--- a/scripts/checkpatch.pl
+++ b/scripts/checkpatch.pl
@@ -174,7 +174,7 @@ if ($tree) {
}
if (!defined $root) {
- print "Must be run from the top-level dir. of a LEDE tree\n";
+ print "Must be run from the top-level dir. of a OpenWrt tree\n";
exit(2);
}
}
diff --git a/scripts/config/mconf.c b/scripts/config/mconf.c
index c366e21fba..540fa911e1 100644
--- a/scripts/config/mconf.c
+++ b/scripts/config/mconf.c
@@ -25,7 +25,7 @@
static const char mconf_readme[] = N_(
"Overview\n"
"--------\n"
-"Some LEDE features may be built directly into the image.\n"
+"Some OpenWrt features may be built directly into the image.\n"
"Some may be made into installable ipkg packages. Some features\n"
"may be completely removed altogether.\n"
"\n"