summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2019-06-25 22:20:44 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-21 20:52:30 +0200
commit39f2f9b1bf719ff11a4497cbfa6de4e3380e35bc (patch)
treef9bd6b011532bf1226c3256c2f470336fe825c2c
parentb5ae70d0530d1a733816f921ae0fe4dd58251fbb (diff)
downloadopenwrt-39f2f9b1bf719ff11a4497cbfa6de4e3380e35bc.tar.gz
openwrt-39f2f9b1bf719ff11a4497cbfa6de4e3380e35bc.tar.bz2
openwrt-39f2f9b1bf719ff11a4497cbfa6de4e3380e35bc.zip
ramips: add MT7615 wireless support for ELECOM WRC-GST devices
ELECOM WRC-1900GST and WRC-2533GST have two MT7615 chips for 2.4/5 GHz wireless. Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com> [WRC-1900GST] Acked-by: NOGUCHI Hiroshi <drvlabo@gmail.com>
-rw-r--r--target/linux/ramips/dts/mt7621_elecom_wrc-gst.dtsi29
-rw-r--r--target/linux/ramips/image/mt7621.mk2
2 files changed, 30 insertions, 1 deletions
diff --git a/target/linux/ramips/dts/mt7621_elecom_wrc-gst.dtsi b/target/linux/ramips/dts/mt7621_elecom_wrc-gst.dtsi
index 03fe467578..43f31cf2b6 100644
--- a/target/linux/ramips/dts/mt7621_elecom_wrc-gst.dtsi
+++ b/target/linux/ramips/dts/mt7621_elecom_wrc-gst.dtsi
@@ -194,7 +194,34 @@
&pcie {
status = "okay";
- /* WRC-xxxxGST has MT7615 for 2.4/5 GHz wifi, but it's not supported */
+};
+
+&pcie0 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x0000>;
+ ieee80211-freq-limit = <2400000 2500000>;
+
+ led {
+ led-sources = <0>;
+ led-active-low;
+ };
+ };
+};
+
+&pcie1 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ ieee80211-freq-limit = <5000000 6000000>;
+
+ led {
+ led-sources = <0>;
+ led-active-low;
+ };
+ };
};
&xhci {
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index ff4dca91b8..848a0785fb 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -291,6 +291,7 @@ define Device/elecom_wrc-1900gst
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
elecom-gst-factory WRC-1900GST 0.00
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware wpad-basic
endef
TARGET_DEVICES += elecom_wrc-1900gst
@@ -302,6 +303,7 @@ define Device/elecom_wrc-2533gst
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
elecom-gst-factory WRC-2533GST 0.00
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware wpad-basic
endef
TARGET_DEVICES += elecom_wrc-2533gst