summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2022-09-30 11:26:47 +0200
committerFelix Fietkau <nbd@nbd.name>2022-09-30 11:28:51 +0200
commit4363faef8a8c975410f001858b010170942aacfc (patch)
tree6724d328151cc7066044fcb98330cfc40f1da54b
parenta0a4cfd83b9f09c4562c065d0017b389b2987263 (diff)
downloadopenwrt-4363faef8a8c975410f001858b010170942aacfc.tar.gz
openwrt-4363faef8a8c975410f001858b010170942aacfc.tar.bz2
openwrt-4363faef8a8c975410f001858b010170942aacfc.zip
kernel: move ubnt ledbar driver to a separate package
Simplifies the tree by removing a non-upstream kernel patch and related kconfig symbols Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--package/kernel/ubnt-ledbar/Makefile34
-rw-r--r--package/kernel/ubnt-ledbar/src/Makefile1
-rw-r--r--package/kernel/ubnt-ledbar/src/leds-ubnt-ledbar.c (renamed from target/linux/generic/files/drivers/leds/leds-ubnt-ledbar.c)0
-rw-r--r--target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch10
-rw-r--r--target/linux/ath79/patches-5.15/0003-leds-add-reset-controller-based-driver.patch10
-rw-r--r--target/linux/generic/config-5.101
-rw-r--r--target/linux/generic/config-5.151
-rw-r--r--target/linux/generic/hack-5.10/800-ubnt-ledbar-driver.patch29
-rw-r--r--target/linux/generic/hack-5.15/800-ubnt-ledbar-driver.patch29
-rw-r--r--target/linux/mediatek/filogic/config-5.151
-rw-r--r--target/linux/mediatek/modules.mk14
-rw-r--r--target/linux/ramips/mt7621/config-5.101
-rw-r--r--target/linux/ramips/mt7621/config-5.151
13 files changed, 45 insertions, 87 deletions
diff --git a/package/kernel/ubnt-ledbar/Makefile b/package/kernel/ubnt-ledbar/Makefile
new file mode 100644
index 0000000000..8fbae9ab94
--- /dev/null
+++ b/package/kernel/ubnt-ledbar/Makefile
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2008-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=ubnt-ledbar
+PKG_RELEASE:=1
+PKG_LICENSE:=GPL-2.0
+
+include $(INCLUDE_DIR)/package.mk
+
+define KernelPackage/leds-ubnt-ledbar
+ SUBMENU:=LED modules
+ TITLE:=Ubiquiti UniFi 6 LR LED support
+ FILES:= \
+ $(PKG_BUILD_DIR)/leds-ubnt-ledbar.ko
+ AUTOLOAD:=$(call AutoProbe,leds-ubnt-ledbar,1)
+ DEPENDS:=@TARGET_mediatek_mt7622 +kmod-i2c-core
+endef
+
+define KernelPackage/leds-ubnt-ledbar/description
+ LED support for Ubiquiti UniFi 6 LR
+endef
+
+define Build/Compile
+ $(KERNEL_MAKE) M="$(PKG_BUILD_DIR)" modules
+endef
+
+$(eval $(call KernelPackage,leds-ubnt-ledbar))
diff --git a/package/kernel/ubnt-ledbar/src/Makefile b/package/kernel/ubnt-ledbar/src/Makefile
new file mode 100644
index 0000000000..a81d9377c0
--- /dev/null
+++ b/package/kernel/ubnt-ledbar/src/Makefile
@@ -0,0 +1 @@
+obj-m := leds-ubnt-ledbar.o
diff --git a/target/linux/generic/files/drivers/leds/leds-ubnt-ledbar.c b/package/kernel/ubnt-ledbar/src/leds-ubnt-ledbar.c
index 555340c5e8..555340c5e8 100644
--- a/target/linux/generic/files/drivers/leds/leds-ubnt-ledbar.c
+++ b/package/kernel/ubnt-ledbar/src/leds-ubnt-ledbar.c
diff --git a/target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch b/target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch
index 7505f682ab..4a721f2af2 100644
--- a/target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch
+++ b/target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch
@@ -13,9 +13,9 @@ Signed-off-by: John Crispin <john@phrozen.org>
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
-@@ -941,6 +941,17 @@ config LEDS_UBNT_LEDBAR
- To compile this driver as a module, choose M here: the module
- will be called leds-ubnt-ledbar.
+@@ -931,6 +931,17 @@ config LEDS_ACER_A500
+
+ source "drivers/leds/blink/Kconfig"
+config LEDS_RESET
+ tristate "LED support for reset-controller API"
@@ -176,10 +176,10 @@ Signed-off-by: John Crispin <john@phrozen.org>
+MODULE_ALIAS("platform:leds-reset");
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
-@@ -94,6 +94,7 @@ obj-$(CONFIG_LEDS_WM831X_STATUS) += leds
+@@ -93,6 +93,7 @@ obj-$(CONFIG_LEDS_TURRIS_OMNIA) += leds
+ obj-$(CONFIG_LEDS_WM831X_STATUS) += leds-wm831x-status.o
obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
obj-$(CONFIG_LEDS_WRAP) += leds-wrap.o
- obj-$(CONFIG_LEDS_UBNT_LEDBAR) += leds-ubnt-ledbar.o
+obj-$(CONFIG_LEDS_RESET) += leds-reset.o
# LED SPI Drivers
diff --git a/target/linux/ath79/patches-5.15/0003-leds-add-reset-controller-based-driver.patch b/target/linux/ath79/patches-5.15/0003-leds-add-reset-controller-based-driver.patch
index f958e79608..7122756c52 100644
--- a/target/linux/ath79/patches-5.15/0003-leds-add-reset-controller-based-driver.patch
+++ b/target/linux/ath79/patches-5.15/0003-leds-add-reset-controller-based-driver.patch
@@ -13,9 +13,9 @@ Signed-off-by: John Crispin <john@phrozen.org>
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
-@@ -886,6 +886,17 @@ config LEDS_UBNT_LEDBAR
- To compile this driver as a module, choose M here: the module
- will be called leds-ubnt-ledbar.
+@@ -876,6 +876,17 @@ source "drivers/leds/blink/Kconfig"
+ comment "Flash and Torch LED drivers"
+ source "drivers/leds/flash/Kconfig"
+config LEDS_RESET
+ tristate "LED support for reset-controller API"
@@ -176,10 +176,10 @@ Signed-off-by: John Crispin <john@phrozen.org>
+MODULE_ALIAS("platform:leds-reset");
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
-@@ -88,6 +88,7 @@ obj-$(CONFIG_LEDS_WM831X_STATUS) += leds
+@@ -87,6 +87,7 @@ obj-$(CONFIG_LEDS_TURRIS_OMNIA) += leds
+ obj-$(CONFIG_LEDS_WM831X_STATUS) += leds-wm831x-status.o
obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
obj-$(CONFIG_LEDS_WRAP) += leds-wrap.o
- obj-$(CONFIG_LEDS_UBNT_LEDBAR) += leds-ubnt-ledbar.o
+obj-$(CONFIG_LEDS_RESET) += leds-reset.o
# LED SPI Drivers
diff --git a/target/linux/generic/config-5.10 b/target/linux/generic/config-5.10
index 498cdff581..873fde044c 100644
--- a/target/linux/generic/config-5.10
+++ b/target/linux/generic/config-5.10
@@ -3045,7 +3045,6 @@ CONFIG_LEDS_TRIGGER_NETDEV=y
CONFIG_LEDS_TRIGGER_TIMER=y
# CONFIG_LEDS_TRIGGER_TRANSIENT is not set
# CONFIG_LEDS_TURRIS_OMNIA is not set
-# CONFIG_LEDS_UBNT_LEDBAR is not set
# CONFIG_LEDS_USER is not set
# CONFIG_LED_TRIGGER_PHY is not set
# CONFIG_LEGACY_PTYS is not set
diff --git a/target/linux/generic/config-5.15 b/target/linux/generic/config-5.15
index 2da2d2393c..547e3ac882 100644
--- a/target/linux/generic/config-5.15
+++ b/target/linux/generic/config-5.15
@@ -3148,7 +3148,6 @@ CONFIG_LEDS_TRIGGER_TIMER=y
# CONFIG_LEDS_TRIGGER_TRANSIENT is not set
# CONFIG_LEDS_TRIGGER_TTY is not set
# CONFIG_LEDS_TURRIS_OMNIA is not set
-# CONFIG_LEDS_UBNT_LEDBAR is not set
# CONFIG_LEDS_USER is not set
# CONFIG_LED_TRIGGER_PHY is not set
# CONFIG_LEGACY_PTYS is not set
diff --git a/target/linux/generic/hack-5.10/800-ubnt-ledbar-driver.patch b/target/linux/generic/hack-5.10/800-ubnt-ledbar-driver.patch
deleted file mode 100644
index 2b4baab456..0000000000
--- a/target/linux/generic/hack-5.10/800-ubnt-ledbar-driver.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/drivers/leds/Kconfig
-+++ b/drivers/leds/Kconfig
-@@ -931,6 +931,16 @@ config LEDS_ACER_A500
-
- source "drivers/leds/blink/Kconfig"
-
-+config LEDS_UBNT_LEDBAR
-+ tristate "LED support for Ubiquiti UniFi 6 LR"
-+ depends on LEDS_CLASS && I2C && OF
-+ help
-+ This option enables support for the Ubiquiti LEDBAR
-+ LED driver.
-+
-+ To compile this driver as a module, choose M here: the module
-+ will be called leds-ubnt-ledbar.
-+
- comment "LED Triggers"
- source "drivers/leds/trigger/Kconfig"
-
---- a/drivers/leds/Makefile
-+++ b/drivers/leds/Makefile
-@@ -93,6 +93,7 @@ obj-$(CONFIG_LEDS_TURRIS_OMNIA) += leds
- obj-$(CONFIG_LEDS_WM831X_STATUS) += leds-wm831x-status.o
- obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
- obj-$(CONFIG_LEDS_WRAP) += leds-wrap.o
-+obj-$(CONFIG_LEDS_UBNT_LEDBAR) += leds-ubnt-ledbar.o
-
- # LED SPI Drivers
- obj-$(CONFIG_LEDS_CR0014114) += leds-cr0014114.o
diff --git a/target/linux/generic/hack-5.15/800-ubnt-ledbar-driver.patch b/target/linux/generic/hack-5.15/800-ubnt-ledbar-driver.patch
deleted file mode 100644
index 146e6ae2f5..0000000000
--- a/target/linux/generic/hack-5.15/800-ubnt-ledbar-driver.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/drivers/leds/Kconfig
-+++ b/drivers/leds/Kconfig
-@@ -876,6 +876,16 @@ source "drivers/leds/blink/Kconfig"
- comment "Flash and Torch LED drivers"
- source "drivers/leds/flash/Kconfig"
-
-+config LEDS_UBNT_LEDBAR
-+ tristate "LED support for Ubiquiti UniFi 6 LR"
-+ depends on LEDS_CLASS && I2C && OF
-+ help
-+ This option enables support for the Ubiquiti LEDBAR
-+ LED driver.
-+
-+ To compile this driver as a module, choose M here: the module
-+ will be called leds-ubnt-ledbar.
-+
- comment "LED Triggers"
- source "drivers/leds/trigger/Kconfig"
-
---- a/drivers/leds/Makefile
-+++ b/drivers/leds/Makefile
-@@ -87,6 +87,7 @@ obj-$(CONFIG_LEDS_TURRIS_OMNIA) += leds
- obj-$(CONFIG_LEDS_WM831X_STATUS) += leds-wm831x-status.o
- obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
- obj-$(CONFIG_LEDS_WRAP) += leds-wrap.o
-+obj-$(CONFIG_LEDS_UBNT_LEDBAR) += leds-ubnt-ledbar.o
-
- # LED SPI Drivers
- obj-$(CONFIG_LEDS_CR0014114) += leds-cr0014114.o
diff --git a/target/linux/mediatek/filogic/config-5.15 b/target/linux/mediatek/filogic/config-5.15
index 963815b264..558894e5e5 100644
--- a/target/linux/mediatek/filogic/config-5.15
+++ b/target/linux/mediatek/filogic/config-5.15
@@ -197,7 +197,6 @@ CONFIG_IRQ_TIME_ACCOUNTING=y
CONFIG_IRQ_WORK=y
CONFIG_JBD2=y
CONFIG_JUMP_LABEL=y
-# CONFIG_LEDS_UBNT_LEDBAR is not set
CONFIG_LIBFDT=y
CONFIG_LOCK_DEBUGGING_SUPPORT=y
CONFIG_LOCK_SPIN_ON_OWNER=y
diff --git a/target/linux/mediatek/modules.mk b/target/linux/mediatek/modules.mk
index 0eb2866cf0..42f2d7d832 100644
--- a/target/linux/mediatek/modules.mk
+++ b/target/linux/mediatek/modules.mk
@@ -39,18 +39,4 @@ endef
$(eval $(call KernelPackage,sdhci-mtk))
-define KernelPackage/leds-ubnt-ledbar
- SUBMENU:=LED modules
- TITLE:=Ubiquiti UniFi 6 LR LED support
- KCONFIG:=CONFIG_LEDS_UBNT_LEDBAR
- FILES:= \
- $(LINUX_DIR)/drivers/leds/leds-ubnt-ledbar.ko
- AUTOLOAD:=$(call AutoProbe,leds-ubnt-ledbar,1)
- DEPENDS:=@TARGET_mediatek_mt7622 +kmod-i2c-core
-endef
-
-define KernelPackage/leds-ubnt-ledbar/description
- LED support for Ubiquiti UniFi 6 LR
-endef
-$(eval $(call KernelPackage,leds-ubnt-ledbar))
diff --git a/target/linux/ramips/mt7621/config-5.10 b/target/linux/ramips/mt7621/config-5.10
index 213fce2c36..1b415f3e66 100644
--- a/target/linux/ramips/mt7621/config-5.10
+++ b/target/linux/ramips/mt7621/config-5.10
@@ -110,7 +110,6 @@ CONFIG_IRQ_MIPS_CPU=y
CONFIG_IRQ_WORK=y
# CONFIG_KERNEL_ZSTD is not set
CONFIG_LED_TRIGGER_PHY=y
-CONFIG_LEDS_UBNT_LEDBAR=y
CONFIG_LIBFDT=y
CONFIG_LOCK_DEBUGGING_SUPPORT=y
CONFIG_LZO_COMPRESS=y
diff --git a/target/linux/ramips/mt7621/config-5.15 b/target/linux/ramips/mt7621/config-5.15
index 79f0a9bc15..a8094fe305 100644
--- a/target/linux/ramips/mt7621/config-5.15
+++ b/target/linux/ramips/mt7621/config-5.15
@@ -111,7 +111,6 @@ CONFIG_IRQ_FORCED_THREADING=y
CONFIG_IRQ_MIPS_CPU=y
CONFIG_IRQ_WORK=y
CONFIG_KMAP_LOCAL=y
-CONFIG_LEDS_UBNT_LEDBAR=y
CONFIG_LED_TRIGGER_PHY=y
CONFIG_LIBFDT=y
CONFIG_LOCK_DEBUGGING_SUPPORT=y