summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2024-04-05 04:42:14 -0400
committerRobert Marko <robimarko@gmail.com>2024-04-25 21:33:51 +0200
commit43be31982366a9604ca5a980dd356d4a72a6d379 (patch)
treeb2fc1b5e24d1ed05170a744aedb14a832dfd0afc
parent7a4df7825eae83650c42ef9839f985f6fdc87b09 (diff)
downloadopenwrt-43be31982366a9604ca5a980dd356d4a72a6d379.tar.gz
openwrt-43be31982366a9604ca5a980dd356d4a72a6d379.tar.bz2
openwrt-43be31982366a9604ca5a980dd356d4a72a6d379.zip
tools/elfutils: organize gnulib import build stage
Organize the Makefile lines involved in gnulib importing and its workarounds. It improves readability and keeps git history organized. Tested-by: Georgi Valkov <gvalkov@gmail.com> # MacOS Signed-off-by: Michael Pratt <mcpratt@pm.me> Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
-rw-r--r--tools/elfutils/Makefile20
1 files changed, 19 insertions, 1 deletions
diff --git a/tools/elfutils/Makefile b/tools/elfutils/Makefile
index f13bd8c944..c7d94d2a47 100644
--- a/tools/elfutils/Makefile
+++ b/tools/elfutils/Makefile
@@ -29,6 +29,24 @@ PKG_SUBDIRS := \
libdwfl \
libdw
+PKG_GNULIB_BASE:=libgnu
+
+PKG_GNULIB_ARGS = \
+ --dir=$(HOST_BUILD_DIR) \
+ --local-dir=$(STAGING_DIR_HOST)/share/gnulib \
+ --source-base=$(PKG_GNULIB_BASE) \
+ --libtool \
+ --import
+
+PKG_GNULIB_MODS = \
+ argp \
+ dirname \
+ fts \
+ obstack \
+ progname \
+ strchrnul \
+ tsearch
+
include $(INCLUDE_DIR)/host-build.mk
ifeq ($(HOST_OS),Darwin)
@@ -55,7 +73,7 @@ endif
Hooks/HostConfigure/Pre := Host/Gnulib $(Hooks/HostConfigure/Pre)
define Host/Gnulib
- cd $(HOST_BUILD_DIR); $(STAGING_DIR_HOST)/bin/gnulib-tool --libtool --source-base=libgnu --import argp dirname fts obstack progname strchrnul tsearch;
+ $(STAGING_DIR_HOST)/bin/gnulib-tool $(PKG_GNULIB_ARGS) $(PKG_GNULIB_MODS);
ln -sf ../lib/eu-config.h $(HOST_BUILD_DIR)/libgnu/;
endef