summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2022-11-21 14:46:42 +0000
committerAlexander Couzens <lynxis@fe80.eu>2022-11-24 15:47:01 +0000
commit4943ce98ffccffcbbd5f7b838af83c7d88d22b16 (patch)
tree44c9f21f12760a6a998b97b5a8ad8cfdd7cc95be
parentc34eab6fd12b4d91ec998b65f86245a3f7a600b4 (diff)
downloadopenwrt-4943ce98ffccffcbbd5f7b838af83c7d88d22b16.tar.gz
openwrt-4943ce98ffccffcbbd5f7b838af83c7d88d22b16.tar.bz2
openwrt-4943ce98ffccffcbbd5f7b838af83c7d88d22b16.zip
kernel/module/iio: add TI am335x ADC driver
Add the iio driver for the embedded ADC in the TI Sitara am335x SoCs. Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
-rw-r--r--package/kernel/linux/modules/iio.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/iio.mk b/package/kernel/linux/modules/iio.mk
index afd14ef47b..c0e37f06c7 100644
--- a/package/kernel/linux/modules/iio.mk
+++ b/package/kernel/linux/modules/iio.mk
@@ -566,3 +566,17 @@ define KernelPackage/iio-fxos8700-spi/description
endef
$(eval $(call KernelPackage,iio-fxos8700-spi))
+
+define KernelPackage/iio-ti-am335x-adc
+ TITLE:= TI Sitara AM335x ADC driver
+ DEPENDS:=@TARGET_omap
+ KCONFIG:=CONFIG_TI_AM335X_ADC
+ FILES:=$(LINUX_DIR)/drivers/iio/adc/ti_am335x_adc.ko
+ AUTOLOAD:=$(call AutoProbe,ti_am335x_adc)
+ $(call AddDepends/iio,+kmod-iio-kfifo-buf)
+endef
+define KernelPackage/iio-ti-am335x-adc/description
+ Driver for the TI AM335x ADC.
+endef
+
+$(eval $(call KernelPackage,iio-ti-am335x-adc))