summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2024-05-08 22:05:00 +0100
committerDaniel Golle <daniel@makrotopia.org>2024-05-08 22:26:02 +0100
commit4e53a3f47ed1312e87b032a839e98813d9605aad (patch)
treecb15b2a3024a1a4bb2e6c6360a529b5a6f851a24
parent3f4347fce0f6bcc57de94c5dc898e2a3967bf4a2 (diff)
downloadopenwrt-4e53a3f47ed1312e87b032a839e98813d9605aad.tar.gz
openwrt-4e53a3f47ed1312e87b032a839e98813d9605aad.tar.bz2
openwrt-4e53a3f47ed1312e87b032a839e98813d9605aad.zip
mtd-utils: nand-tuils: build and package 'nandbiterrs'
The 'nandbiterrs' tool is useful to find out of bit error correction of NAND is working as expected by deliberately introducing bit errors and telling up to which number they can be corrected. Enable build of the testing tools and package the 'nandbiterrs' tool as part of the nand-utils package. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
-rw-r--r--package/utils/mtd-utils/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/utils/mtd-utils/Makefile b/package/utils/mtd-utils/Makefile
index fd1cb75e51..c0ea0abbcb 100644
--- a/package/utils/mtd-utils/Makefile
+++ b/package/utils/mtd-utils/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mtd-utils
PKG_VERSION:=2.1.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://infraroot.at/pub/mtd/
@@ -59,7 +59,7 @@ endef
MAKE_FLAGS += LDLIBS+="$(LIBGCC_S)"
CONFIGURE_ARGS += \
- --disable-tests \
+ --enable-tests \
--without-crypto \
--without-xattr \
--without-zstd \
@@ -76,7 +76,8 @@ endef
define Package/nand-utils/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) \
- $(PKG_INSTALL_DIR)/usr/sbin/{flash_erase,nanddump,nandwrite,nandtest,mtdinfo} $(1)/usr/sbin/
+ $(PKG_INSTALL_DIR)/usr/sbin/{flash_erase,nanddump,nandwrite,nandtest,mtdinfo} \
+ $(PKG_INSTALL_DIR)/usr/lib/mtd-utils/nandbiterrs $(1)/usr/sbin/
endef
$(eval $(call BuildPackage,ubi-utils))