summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Balerdi <lanchon@gmail.com>2024-09-24 17:43:49 -0300
committerRobert Marko <robimarko@gmail.com>2024-11-17 12:24:43 +0100
commit5583d2318966d5d5dcdbdec2e34b8815d3f6419a (patch)
tree42bf1c2b9311f5113d4547ecbf011215b8c4a9df
parentbdfae5a16679b41746b836a8f5dee66d1c778e41 (diff)
downloadopenwrt-5583d2318966d5d5dcdbdec2e34b8815d3f6419a.tar.gz
openwrt-5583d2318966d5d5dcdbdec2e34b8815d3f6419a.tar.bz2
openwrt-5583d2318966d5d5dcdbdec2e34b8815d3f6419a.zip
ipq807x: nbg7815: use the standard eMMC sysupgrade code
Note that the old ad-hoc method did not explicitly align backup data to 64 KiB boundaries. Signed-off-by: Rodrigo Balerdi <lanchon@gmail.com> Link: https://github.com/openwrt/openwrt/pull/16505 Signed-off-by: Robert Marko <robimarko@gmail.com>
-rw-r--r--target/linux/qualcommax/image/ipq807x.mk2
-rw-r--r--target/linux/qualcommax/ipq807x/base-files/lib/upgrade/platform.sh14
2 files changed, 8 insertions, 8 deletions
diff --git a/target/linux/qualcommax/image/ipq807x.mk b/target/linux/qualcommax/image/ipq807x.mk
index faefb479c2..401f455585 100644
--- a/target/linux/qualcommax/image/ipq807x.mk
+++ b/target/linux/qualcommax/image/ipq807x.mk
@@ -446,7 +446,7 @@ define Device/zyxel_nbg7815
DEVICE_MODEL := NBG7815
DEVICE_DTS_CONFIG := config@nbg7815
SOC := ipq8074
- DEVICE_PACKAGES := ipq-wifi-zyxel_nbg7815 kmod-ath11k-pci \
+ DEVICE_PACKAGES := kmod-fs-f2fs f2fs-tools ipq-wifi-zyxel_nbg7815 kmod-ath11k-pci \
kmod-bluetooth kmod-hwmon-tmp103
endef
TARGET_DEVICES += zyxel_nbg7815
diff --git a/target/linux/qualcommax/ipq807x/base-files/lib/upgrade/platform.sh b/target/linux/qualcommax/ipq807x/base-files/lib/upgrade/platform.sh
index 808acac684..f822f6291d 100644
--- a/target/linux/qualcommax/ipq807x/base-files/lib/upgrade/platform.sh
+++ b/target/linux/qualcommax/ipq807x/base-files/lib/upgrade/platform.sh
@@ -251,14 +251,13 @@ platform_do_upgrade() {
[ -z "$config_mtdnum" ] && reboot
part_num="$(hexdump -e '1/1 "%01x|"' -n 1 -s 168 -C /dev/mtd$config_mtdnum | cut -f 1 -d "|" | head -n1)"
if [ "$part_num" -eq "0" ]; then
- kernelname="0:HLOS"
- rootfsname="rootfs"
- mmc_do_upgrade "$1"
+ CI_KERNPART="0:HLOS"
+ CI_ROOTPART="rootfs"
else
- kernelname="0:HLOS_1"
- rootfsname="rootfs_1"
- mmc_do_upgrade "$1"
+ CI_KERNPART="0:HLOS_1"
+ CI_ROOTPART="rootfs_1"
fi
+ emmc_do_upgrade "$1"
;;
*)
default_do_upgrade "$1"
@@ -268,7 +267,8 @@ platform_do_upgrade() {
platform_copy_config() {
case "$(board_name)" in
- spectrum,sax1v1k)
+ spectrum,sax1v1k|\
+ zyxel,nbg7815)
emmc_copy_config
;;
esac