summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-11-30 10:00:41 +0100
committerMathias Kresin <dev@kresin.me>2016-11-30 10:13:14 +0100
commit59261cbf38001b121f94642a4f225fbe082b1b7d (patch)
tree3bb0d91d17c88d4314215b8b7adf827a971d0e1d
parentd52676d1ea51bcfc947970085184fe4d18638ccd (diff)
downloadopenwrt-59261cbf38001b121f94642a4f225fbe082b1b7d.tar.gz
openwrt-59261cbf38001b121f94642a4f225fbe082b1b7d.tar.bz2
openwrt-59261cbf38001b121f94642a4f225fbe082b1b7d.zip
docs: remove all refrences in Makefiles/scripts
The SDK Makefile still trys to copy the docs folder which was removed with 882f4d2d63272abce8c1966983aa10178e2e971f. This causes an SDK build error. All other removals are just cleanup. Signed-off-by: Mathias Kresin <dev@kresin.me>
-rw-r--r--include/toplevel.mk6
-rwxr-xr-xscripts/checkpatch.pl2
-rwxr-xr-xscripts/symlink-tree.sh1
-rw-r--r--target/sdk/Makefile2
4 files changed, 2 insertions, 9 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 81329ac414..f31884d3fe 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -223,12 +223,6 @@ package/symlinks-clean:
help:
cat README
-docs docs/compile: FORCE
- @$(_SINGLE)$(SUBMAKE) -C docs compile
-
-docs/clean: FORCE
- @$(_SINGLE)$(SUBMAKE) -C docs clean
-
distclean:
rm -rf bin build_dir .config* dl feeds key-build* logs package/feeds package/openwrt-packages staging_dir tmp
@$(_SINGLE)$(SUBMAKE) -C scripts/config clean
diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
index 9858e62fbb..c4b7437b90 100755
--- a/scripts/checkpatch.pl
+++ b/scripts/checkpatch.pl
@@ -391,7 +391,7 @@ sub top_of_openwrt_tree {
my @tree_check = (
"BSDmakefile", "Config.in", "LICENSE", "Makefile", "README",
- "docs", "feeds.conf.default", "include", "package", "rules.mk",
+ "feeds.conf.default", "include", "package", "rules.mk",
"scripts", "target", "toolchain", "tools"
);
diff --git a/scripts/symlink-tree.sh b/scripts/symlink-tree.sh
index 3b7ce4718d..aa169e2455 100755
--- a/scripts/symlink-tree.sh
+++ b/scripts/symlink-tree.sh
@@ -10,7 +10,6 @@ FILES="
Makefile
README
dl
- docs
feeds.conf.default
include
package
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index 54c50ab760..de77d1a31a 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -67,7 +67,7 @@ all: compile
$(BIN_DIR)/$(SDK_NAME).tar.xz: clean
mkdir -p $(SDK_BUILD_DIR)/dl $(SDK_BUILD_DIR)/package
- $(CP) -L $(INCLUDE_DIR) $(SCRIPT_DIR) $(TOPDIR)/docs $(SDK_BUILD_DIR)/
+ $(CP) -L $(INCLUDE_DIR) $(SCRIPT_DIR) $(SDK_BUILD_DIR)/
$(TAR) -cf - -C $(TOPDIR) \
`cd $(TOPDIR); find $(KDIR_BASE) -name \*.ko` \
`cd $(TOPDIR); find $(KDIR_BASE)/firmware/ -newer $(KDIR_BASE)/firmware/Makefile \