summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Niklas Burfeind <git@aiyionpri.me>2021-08-27 19:25:47 +0200
committerDavid Bauer <mail@david-bauer.net>2021-09-01 00:20:08 +0200
commit5cc05358006d592d3712e6565c253762819fe010 (patch)
treef2953604a791e9f3ba7907c2ed8343e0c70a32f0
parent085c67762ddac7133b47c6e3825d944c41a5e174 (diff)
downloadopenwrt-5cc05358006d592d3712e6565c253762819fe010.tar.gz
openwrt-5cc05358006d592d3712e6565c253762819fe010.tar.bz2
openwrt-5cc05358006d592d3712e6565c253762819fe010.zip
ath79: add support for onion omega
The Onion Omega is a hardware development platform with built-in WiFi. https://onioniot.github.io/wiki/ Specifications: - QCA9331 @ 400 MHz (MIPS 24Kc Big-Endian Processor) - 64MB of DDR2 RAM running at 400 MHz - 16MB of on-board flash storage - Support for USB 2.0 - Support for Ethernet at 100 Mbps - 802.11b/g/n WiFi at 150 Mbps - 18 digital GPIOs - A single Serial UART - Support for SPI - Support for I2S Flash instructions: The device is running OpenWrt upon release using the ar71xx target. Both a sysupgrade and uploading the factory image using u-boots web-UI do work fine. Depending on the ssh client, it might be necessary to enable outdated KeyExchange methods e.g. in the clients ssh-config: Host 192.168.1.1 KexAlgorithms +diffie-hellman-group1-sha1 The stock credentials are: root onioneer For u-boots web-UI manually configure `192.168.1.2/24` on your computer, connect to `192.168.1.1`. MAC addresses as verified by OEM firmware: 2G phy0 label LAN eth0 label - 1 LAN is only available in combination with an optional expansion dock. Based on vendor acked commit: commit 5cd49bb067ca ("ar71xx: add support for Onion Omega") Partly reverts: commit fc553c7e4c8e ("ath79: drop unused/incomplete dts") Signed-off-by: Jan-Niklas Burfeind <git@aiyionpri.me> (cherry picked from commit d98738b5c118fc45068b45f07b8b6938e91f35d2)
-rw-r--r--target/linux/ath79/dts/ar9331_onion_omega.dts125
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ath79/image/generic.mk13
3 files changed, 139 insertions, 0 deletions
diff --git a/target/linux/ath79/dts/ar9331_onion_omega.dts b/target/linux/ath79/dts/ar9331_onion_omega.dts
new file mode 100644
index 0000000000..4039b9e203
--- /dev/null
+++ b/target/linux/ath79/dts/ar9331_onion_omega.dts
@@ -0,0 +1,125 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9331.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ model = "Onion Omega";
+ compatible = "onion,omega", "qca,ar9331";
+
+ aliases {
+ serial0 = &uart;
+ label-mac-device = &wmac;
+ led-boot = &led_system;
+ led-failsafe = &led_system;
+ led-running = &led_system;
+ led-upgrade = &led_system;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_system: system {
+ label = "amber:system";
+ gpios = <&gpio 27 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 11 GPIO_ACTIVE_HIGH>;
+ debounce-interval = <60>;
+ };
+ };
+
+ reg_usb_vbus: reg_usb_vbus {
+ compatible = "regulator-fixed";
+ regulator-name = "usb_vbus";
+ regulator-min-microvolt = <5000000>;
+ regulator-max-microvolt = <5000000>;
+ gpio = <&gpio 8 GPIO_ACTIVE_HIGH>;
+ enable-active-high;
+ };
+};
+
+&ref {
+ clock-frequency = <25000000>;
+};
+
+&usb {
+ status = "okay";
+
+ vbus-supply = <&reg_usb_vbus>;
+ dr_mode = "host";
+};
+
+&usb_phy {
+ status = "okay";
+};
+
+&eth0 {
+ status = "okay";
+
+ compatible = "syscon", "simple-mfd";
+};
+
+&eth1 {
+ status = "okay";
+
+ mtd-mac-address = <&uboot 0x1fc00>;
+ mtd-mac-address-increment = <(-1)>;
+
+ gmac-config {
+ device = <&gmac>;
+ switch-phy-addr-swap = <4>;
+ switch-phy-swap = <4>;
+ };
+};
+
+&spi {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ spi-max-frequency = <25000000>;
+ reg = <0>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ uboot: partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x020000>;
+ read-only;
+ };
+
+ partition@20000 {
+ compatible = "tplink,firmware";
+ label = "firmware";
+ reg = <0x020000 0xfd0000>;
+ };
+
+ art: partition@ff0000 {
+ label = "art";
+ reg = <0xff0000 0x010000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&wmac {
+ status = "okay";
+
+ mtd-cal-data = <&art 0x1000>;
+
+ mtd-mac-address = <&uboot 0x1fc00>;
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index 31c0f11861..c4d9d76941 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -46,6 +46,7 @@ ath79_setup_interfaces()
netgear,ex7300|\
ocedo,koala|\
ocedo,raccoon|\
+ onion,omega|\
openmesh,mr600-v1|\
openmesh,mr600-v2|\
openmesh,mr900-v1|\
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index ce4e462a40..5ba64b9803 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1603,6 +1603,19 @@ define Device/ocedo_ursus
endef
TARGET_DEVICES += ocedo_ursus
+define Device/onion_omega
+ $(Device/tplink-16mlzma)
+ SOC := ar9331
+ DEVICE_VENDOR := Onion
+ DEVICE_MODEL := Omega
+ DEVICE_PACKAGES := kmod-usb-chipidea2
+ SUPPORTED_DEVICES += onion-omega
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
+ IMAGE_SIZE := 16192k
+ TPLINK_HWID := 0x04700001
+endef
+TARGET_DEVICES += onion_omega
+
define Device/openmesh_common_64k
DEVICE_VENDOR := OpenMesh
DEVICE_PACKAGES := uboot-envtools