summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-11-01 18:40:03 +0100
committerFelix Fietkau <nbd@nbd.name>2021-11-01 18:41:20 +0100
commit6738820bf637fd705ea7e61acf4f694e1bcda313 (patch)
tree8d69e7a4743e4eca559b8df226589ed3f5c2a893
parentf3a28b6bcf984dc55ec2d675ba75f0d3bc794eb9 (diff)
downloadopenwrt-6738820bf637fd705ea7e61acf4f694e1bcda313.tar.gz
openwrt-6738820bf637fd705ea7e61acf4f694e1bcda313.tar.bz2
openwrt-6738820bf637fd705ea7e61acf4f694e1bcda313.zip
build: fix bpf toolchain dependency for qosify
Add hidden symbols to fix defaults with CONFIG_DEVEL unset Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--include/bpf.mk2
-rw-r--r--package/network/config/qosify/Makefile2
-rw-r--r--toolchain/Config.in13
-rw-r--r--tools/Makefile2
4 files changed, 17 insertions, 2 deletions
diff --git a/include/bpf.mk b/include/bpf.mk
index 3dc65c7685..5211ec4434 100644
--- a/include/bpf.mk
+++ b/include/bpf.mk
@@ -1,3 +1,5 @@
+BPF_DEPENDS := @HAS_BPF_TOOLCHAIN
+
ifneq ($(CONFIG_BPF_TOOLCHAIN_HOST),)
BPF_TOOLCHAIN_HOST_PATH:=$(call qstrip,$(CONFIG_BPF_TOOLCHAIN_HOST_PATH))
ifneq ($(BPF_TOOLCHAIN_HOST_PATH),)
diff --git a/package/network/config/qosify/Makefile b/package/network/config/qosify/Makefile
index 28dedf874d..a7532d2906 100644
--- a/package/network/config/qosify/Makefile
+++ b/package/network/config/qosify/Makefile
@@ -29,7 +29,7 @@ define Package/qosify
CATEGORY:=Kernel modules
SUBMENU:=Network Support
TITLE:=A simple QoS solution based eBPF + CAKE
- DEPENDS:=+libbpf +libubox +libubus +kmod-sched-cake +tc-full @!BPF_TOOLCHAIN_NONE
+ DEPENDS:=+libbpf +libubox +libubus +kmod-sched-cake +tc-full $(BPF_DEPENDS)
endef
define Build/Compile
diff --git a/toolchain/Config.in b/toolchain/Config.in
index 1515135806..b8b4cfeb88 100644
--- a/toolchain/Config.in
+++ b/toolchain/Config.in
@@ -46,9 +46,11 @@ menuconfig TARGET_OPTIONS
bool "None"
config BPF_TOOLCHAIN_HOST
+ select USE_LLVM_HOST
bool "Use host LLVM toolchain"
config BPF_TOOLCHAIN_BUILD_LLVM
+ select USE_LLVM_BUILD
bool "Build LLVM toolchain for eBPF"
help
If enabled, a LLVM toolchain for building eBPF binaries will be built.
@@ -292,6 +294,17 @@ config GDB_PYTHON
help
Enable the python bindings for GDB to allow using python in the gdb shell.
+config HAS_BPF_TOOLCHAIN
+ bool
+
+config USE_LLVM_HOST
+ select HAS_BPF_TOOLCHAIN
+ bool
+
+config USE_LLVM_BUILD
+ select HAS_BPF_TOOLCHAIN
+ bool
+
config USE_GLIBC
default y if !TOOLCHAINOPTS && !EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN && (arc)
bool
diff --git a/tools/Makefile b/tools/Makefile
index f070692942..ad8eeb31a4 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -35,7 +35,7 @@ tools-$(CONFIG_TARGET_mxs) += elftosb sdimage
tools-$(CONFIG_TARGET_tegra) += cbootimage cbootimage-configs
tools-$(CONFIG_USES_MINOR) += kernel2minor
tools-$(CONFIG_USE_SPARSE) += sparse
-tools-$(CONFIG_BPF_TOOLCHAIN_BUILD_LLVM) += llvm-bpf
+tools-$(CONFIG_USE_LLVM_BUILD) += llvm-bpf
# builddir dependencies
$(curdir)/autoconf/compile := $(curdir)/m4/compile