summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2024-06-09 16:04:58 -0700
committerRobert Marko <robimarko@gmail.com>2024-06-13 18:10:27 +0200
commit6b03050192a6fbcb79121f7ce1b6835750ba3cf0 (patch)
tree7824066805f48f903c6de1edb7809bbf4af69bab
parent0a76244a72157ff06d2c7d309b477522d4975a95 (diff)
downloadopenwrt-6b03050192a6fbcb79121f7ce1b6835750ba3cf0.tar.gz
openwrt-6b03050192a6fbcb79121f7ce1b6835750ba3cf0.tar.bz2
openwrt-6b03050192a6fbcb79121f7ce1b6835750ba3cf0.zip
mac80211: remove mtd-cal-data
All usages of mtd-cal-data have been removed. To avoid submissions that rely on this deprecated behavior, remove it. Signed-off-by: Rosen Penev <rosenp@gmail.com> Link: https://github.com/openwrt/openwrt/pull/15671 Signed-off-by: Robert Marko <robimarko@gmail.com>
-rw-r--r--package/kernel/mac80211/Makefile2
-rw-r--r--package/kernel/mac80211/patches/ath9k/552-ath9k-ahb_of.patch46
2 files changed, 2 insertions, 46 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 566cfdd7b2..79ef87b998 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mac80211
PKG_VERSION:=6.6.15
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPL-2.0-only
PKG_LICENSE_FILES:=COPYING
diff --git a/package/kernel/mac80211/patches/ath9k/552-ath9k-ahb_of.patch b/package/kernel/mac80211/patches/ath9k/552-ath9k-ahb_of.patch
index 637e607e36..29e66c070c 100644
--- a/package/kernel/mac80211/patches/ath9k/552-ath9k-ahb_of.patch
+++ b/package/kernel/mac80211/patches/ath9k/552-ath9k-ahb_of.patch
@@ -16,7 +16,7 @@
static const struct platform_device_id ath9k_platform_id_table[] = {
{
-@@ -69,6 +77,236 @@ static const struct ath_bus_ops ath_ahb_
+@@ -69,6 +77,192 @@ static const struct ath_bus_ops ath_ahb_
.eeprom_read = ath_ahb_eeprom_read,
};
@@ -25,47 +25,6 @@
+#define QCA955X_DDR_CTL_CONFIG 0x108
+#define QCA955X_DDR_CTL_CONFIG_ACT_WMAC BIT(23)
+
-+static int of_get_wifi_cal(struct device_node *np, struct ath9k_platform_data *pdata)
-+{
-+#ifdef CONFIG_MTD
-+ struct device_node *mtd_np = NULL;
-+ size_t retlen;
-+ int size, ret;
-+ struct mtd_info *mtd;
-+ const char *part;
-+ const __be32 *list;
-+ phandle phandle;
-+
-+ list = of_get_property(np, "mtd-cal-data", &size);
-+ if (!list)
-+ return 0;
-+
-+ if (size != (2 * sizeof(*list)))
-+ return 1;
-+
-+ phandle = be32_to_cpup(list++);
-+ if (phandle)
-+ mtd_np = of_find_node_by_phandle(phandle);
-+
-+ if (!mtd_np)
-+ return 1;
-+
-+ part = of_get_property(mtd_np, "label", NULL);
-+ if (!part)
-+ part = mtd_np->name;
-+
-+ mtd = get_mtd_device_nm(part);
-+ if (IS_ERR(mtd))
-+ return 1;
-+
-+ ret = mtd_read(mtd, be32_to_cpup(list), sizeof(pdata->eeprom_data),
-+ &retlen, (u8*)pdata->eeprom_data);
-+ put_mtd_device(mtd);
-+
-+#endif
-+ return 0;
-+}
-+
+static int ar913x_wmac_reset(void)
+{
+ ath79_device_reset_set(AR913X_RESET_AMBA2WMAC);
@@ -243,9 +202,6 @@
+
+ pdata->get_mac_revision = data->soc_revision;
+
-+ if (of_get_wifi_cal(pdev->dev.of_node, pdata))
-+ dev_err(&pdev->dev, "failed to load calibration data from mtd device\n");
-+
+ return data->dev_id;
+}
+#endif