summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2024-11-14 22:57:02 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2024-11-16 14:22:22 +0100
commit71c14cbee5aa5f1924191252c07a69b7e6aabd29 (patch)
treed91363f470eb844264fe799e5c9a81dee6e9b46a
parent487ca61f917f9308222faf481ad8be4e2cef0c90 (diff)
downloadopenwrt-71c14cbee5aa5f1924191252c07a69b7e6aabd29.tar.gz
openwrt-71c14cbee5aa5f1924191252c07a69b7e6aabd29.tar.bz2
openwrt-71c14cbee5aa5f1924191252c07a69b7e6aabd29.zip
build: apk: Remove /run/apk/db.lock
Do not add the file /run/apk/db.lock to the root file system. The /run folder should be on a tmpfs. At runtime we should make /run point to a tmpfs. At build time we should just remove the folder. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> Link: https://github.com/openwrt/openwrt/pull/16961 Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
-rw-r--r--package/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index 2c7cd58879..3c6621b81c 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -101,6 +101,7 @@ ifneq ($(CONFIG_USE_APK),)
$(call apk,$(TARGET_DIR)) add --no-cache --initdb --no-scripts --arch $(ARCH_PACKAGES) \
--repositories-file /dev/null --repository file://$(PACKAGE_DIR_ALL)/packages.adb \
$$(cat $(TMP_DIR)/apk_install_list)
+ rm -rf $(TARGET_DIR)/run
else
$(file >$(TMP_DIR)/opkg_install_list,\
$(call opkg_package_files,\