summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-12 13:27:49 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-12 13:27:49 +0000
commit7304953292a00d8e6d00ab19259294ebcb95dd80 (patch)
tree9e969d1867f72ddb4ce335e505a0f1ea3fc5c649
parent70aaa116eb0b340e44f75e94e2159d41d8b2ecde (diff)
downloadopenwrt-7304953292a00d8e6d00ab19259294ebcb95dd80.tar.gz
openwrt-7304953292a00d8e6d00ab19259294ebcb95dd80.tar.bz2
openwrt-7304953292a00d8e6d00ab19259294ebcb95dd80.zip
convert remaining tools to $(HOST_STATIC_LINKING) (#12012)
SVN-Revision: 33148
-rw-r--r--tools/lzma/Makefile4
-rw-r--r--tools/mkimage/Makefile2
-rw-r--r--tools/padjffs2/Makefile2
-rw-r--r--tools/sed/Makefile2
-rw-r--r--tools/squashfs4/Makefile2
5 files changed, 6 insertions, 6 deletions
diff --git a/tools/lzma/Makefile b/tools/lzma/Makefile
index 00ed3dc425..6e01051a3a 100644
--- a/tools/lzma/Makefile
+++ b/tools/lzma/Makefile
@@ -21,8 +21,8 @@ UTIL_DIR=$(HOST_BUILD_DIR)/C/LzmaUtil
ALONE_DIR=$(HOST_BUILD_DIR)/CPP/7zip/Compress/LZMA_Alone
define Host/Compile
- $(MAKE) -C $(UTIL_DIR) -f makefile.gcc LDFLAGS="-static"
- $(MAKE) -C $(ALONE_DIR) -f makefile.gcc LDFLAGS="-static"
+ $(MAKE) -C $(UTIL_DIR) -f makefile.gcc LDFLAGS="$(HOST_STATIC_LINKING)"
+ $(MAKE) -C $(ALONE_DIR) -f makefile.gcc LDFLAGS="$(HOST_STATIC_LINKING)"
endef
define Host/Install
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index e26d6b75c9..373d9bebb8 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -21,7 +21,7 @@ include $(INCLUDE_DIR)/host-build.mk
define Host/Compile
rm -f $(HOST_BUILD_DIR)/tools/.depend
touch $(HOST_BUILD_DIR)/include/config.h
- $(MAKE) -C $(HOST_BUILD_DIR) BUILD_DIR= BIN_FILES-y="mkimage" HOSTLDFLAGS="-static" tools
+ $(MAKE) -C $(HOST_BUILD_DIR) BUILD_DIR= BIN_FILES-y="mkimage" HOSTLDFLAGS="$(HOST_STATIC_LINKING)" tools
endef
define Host/Install
diff --git a/tools/padjffs2/Makefile b/tools/padjffs2/Makefile
index 3f033c0c2b..4535735d69 100644
--- a/tools/padjffs2/Makefile
+++ b/tools/padjffs2/Makefile
@@ -19,7 +19,7 @@ define Host/Prepare
endef
define Host/Compile
- $(MAKE) -C $(HOST_BUILD_DIR) LDFLAGS="-static"
+ $(MAKE) -C $(HOST_BUILD_DIR) LDFLAGS="$(HOST_STATIC_LINKING)"
endef
define Host/Configure
diff --git a/tools/sed/Makefile b/tools/sed/Makefile
index 210feceb71..522ae70d8b 100644
--- a/tools/sed/Makefile
+++ b/tools/sed/Makefile
@@ -27,7 +27,7 @@ HOST_CONFIGURE_VARS += \
ac_cv_header_selinux_selinux_h=no \
define Host/Compile
- $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" LDFLAGS="-static"
+ $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" LDFLAGS="$(HOST_STATIC_LINKING)"
endef
define Host/Install
diff --git a/tools/squashfs4/Makefile b/tools/squashfs4/Makefile
index 4b917c59cf..b838b46c55 100644
--- a/tools/squashfs4/Makefile
+++ b/tools/squashfs4/Makefile
@@ -26,7 +26,7 @@ define Host/Compile
XATTR_SUPPORT= \
LZMA_LIB="$(STAGING_DIR_HOST)/lib/liblzma.a" \
EXTRA_CFLAGS="-I$(STAGING_DIR_HOST)/include" \
- EXTRA_LDFLAGS="-static" \
+ EXTRA_LDFLAGS="$(HOST_STATIC_LINKING)" \
mksquashfs unsquashfs
endef