summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-03-03 16:09:04 +0100
committerFelix Fietkau <nbd@nbd.name>2021-03-03 16:09:59 +0100
commit785ab2b62c8d9366023095641f2ba237e2b0ed8e (patch)
tree40d565f4bea52d772232b4ed6cb6383a7b23e240
parent5a3562cd1da77348f8b542f8e32f75125c492474 (diff)
downloadopenwrt-785ab2b62c8d9366023095641f2ba237e2b0ed8e.tar.gz
openwrt-785ab2b62c8d9366023095641f2ba237e2b0ed8e.tar.bz2
openwrt-785ab2b62c8d9366023095641f2ba237e2b0ed8e.zip
build: use numeric uid/gid on cpio calls
There are systems that don't have the 'root' group, so don't rely on host specific user/group names Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--include/image.mk2
-rw-r--r--include/kernel-defaults.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index 7f0d27b746..993de5ff53 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -301,7 +301,7 @@ endif
ifdef CONFIG_TARGET_ROOTFS_CPIOGZ
define Image/Build/cpiogz
- ( cd $(TARGET_DIR); find . | $(STAGING_DIR_HOST)/bin/cpio -o -H newc -R root:root | gzip -9n >$(BIN_DIR)/$(IMG_ROOTFS).cpio.gz )
+ ( cd $(TARGET_DIR); find . | $(STAGING_DIR_HOST)/bin/cpio -o -H newc -R 0:0 | gzip -9n >$(BIN_DIR)/$(IMG_ROOTFS).cpio.gz )
endef
endif
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index ade31b0dc1..4b0b136a03 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -163,7 +163,7 @@ ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS_SEPARATE),y)
ifeq ($(CONFIG_EXTERNAL_CPIO),y)
$(CP) $(CONFIG_EXTERNAL_CPIO) $(KERNEL_BUILD_DIR)/initrd.cpio
else
- ( cd $(TARGET_DIR); find . | $(STAGING_DIR_HOST)/bin/cpio -o -H newc -R root:root > $(KERNEL_BUILD_DIR)/initrd.cpio )
+ ( cd $(TARGET_DIR); find . | $(STAGING_DIR_HOST)/bin/cpio -o -H newc -R 0:0 > $(KERNEL_BUILD_DIR)/initrd.cpio )
endif
$(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_BZIP2),bzip2 -9 -c < $(KERNEL_BUILD_DIR)/initrd.cpio > $(KERNEL_BUILD_DIR)/initrd.cpio.bzip2)
$(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_GZIP),gzip -f -S .gzip -9n $(KERNEL_BUILD_DIR)/initrd.cpio)