summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2024-04-17 13:48:41 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2024-04-25 16:34:25 +0200
commit82df12e98a0e972221389147c30f248eed52ddcf (patch)
tree1f946a02ad2a15fea43b74d83f55624da0b9b248
parent91224742263aa322f3a289219d06ce8860a36cc6 (diff)
downloadopenwrt-82df12e98a0e972221389147c30f248eed52ddcf.tar.gz
openwrt-82df12e98a0e972221389147c30f248eed52ddcf.tar.bz2
openwrt-82df12e98a0e972221389147c30f248eed52ddcf.zip
sunxi: update image Makefile to reflect updated DTS structure in 6.6
For the ARM arch on 6.6, DTS files are moved into their vendor directories, mimicking arm64. Reflect this in the image Makefile. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
-rw-r--r--target/linux/sunxi/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index cc1c1ba42d..d462880e90 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -34,7 +34,11 @@ define Device/Default
KERNEL := kernel-bin | uImage none
IMAGES := sdcard.img.gz
IMAGE/sdcard.img.gz := sunxi-sdcard | append-metadata | gzip
+ifneq ($(LINUX_6_1),)
SUNXI_DTS_DIR :=
+else
+ SUNXI_DTS_DIR :=allwinner/
+endif
SUNXI_DTS = $$(SUNXI_DTS_DIR)$$(SOC)-$(lastword $(subst _, ,$(1)))
endef