summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Kennedy <hurricos@gmail.com>2024-04-24 19:38:59 -0400
committerStijn Tintel <stijn@linux-ipv6.be>2024-04-25 03:00:17 +0300
commit84a48ce400b2c7b0779f51e83c68de5f8ec58ffd (patch)
treea97e8df54dda49112739ca8be8997b9c936a8748
parent9c8f2d7c2daef6f20fcb6217d7f35a1649ac5fda (diff)
downloadopenwrt-84a48ce400b2c7b0779f51e83c68de5f8ec58ffd.tar.gz
openwrt-84a48ce400b2c7b0779f51e83c68de5f8ec58ffd.tar.bz2
openwrt-84a48ce400b2c7b0779f51e83c68de5f8ec58ffd.zip
mpc85xx: fix address config for ws-ap3825i
In commit 6a8b83159389 ("mpc85xx: p1010: change wrapper address of simple image devices"), we adjusted the wrapper address in the recipe code for all mpc85xx simpleimage devices, including the Extreme Networks WS-AP3825i. However, we did not also adjust the KERNEL_LOADADDR and KERNEL_ENTRY config values for this board. This broke the simpleimage wrapper loader, causing GitHub issue #15237. Adjust those config values so we go back to pointing at the right address. We don't exactly need the memory, but it's also not exactly a punishment in this case. Run-tested on a ws-ap3825i. Fixes: commit 6a8b83159389 ("mpc85xx: p1010: change wrapper address of simple image devices") Tested-by: Martin Kennedy <hurricos@gmail.com> Signed-off-by: Martin Kennedy <hurricos@gmail.com>
-rw-r--r--target/linux/mpc85xx/image/p1020.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/mpc85xx/image/p1020.mk b/target/linux/mpc85xx/image/p1020.mk
index 1d18a63dc0..26b8167553 100644
--- a/target/linux/mpc85xx/image/p1020.mk
+++ b/target/linux/mpc85xx/image/p1020.mk
@@ -79,8 +79,8 @@ define Device/extreme-networks_ws-ap3825i
DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
BLOCKSIZE := 128k
KERNEL_NAME := simpleImage.ws-ap3825i
- KERNEL_ENTRY := 0x1000000
- KERNEL_LOADADDR := 0x1000000
+ KERNEL_ENTRY := 0x1500000
+ KERNEL_LOADADDR := 0x1500000
KERNEL = kernel-bin | fit none $(KDIR)/image-$$(DEVICE_DTS).dtb
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata