summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2024-03-15 12:50:43 +0100
committerRobert Marko <robimarko@gmail.com>2024-03-15 15:25:03 +0100
commit8fb23465ca90073ae9313ee366af302930ec1d6c (patch)
treec117584121fffa8d79ebf77b5a389cbd956625ec
parent08f1c36d0081ca183dce2c17cd5d0692ad63e430 (diff)
downloadopenwrt-8fb23465ca90073ae9313ee366af302930ec1d6c.tar.gz
openwrt-8fb23465ca90073ae9313ee366af302930ec1d6c.tar.bz2
openwrt-8fb23465ca90073ae9313ee366af302930ec1d6c.zip
kernel: modules: video: select drm-exec and drm-suballoc-helper for AMDGPU
drm-amdgpu and drm-radeon require drm-exec and/or drm-suballoc-helper in 6.6, so since we have them packaged separately include them when required. Fixes: 5b08b5600720 ("kernel: modules: video: adapt for kernel 6.6") Signed-off-by: Robert Marko <robimarko@gmail.com>
-rw-r--r--package/kernel/linux/modules/video.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index 1e12ffbb40..16c4f51f5b 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -374,7 +374,8 @@ define KernelPackage/drm-amdgpu
TITLE:=AMDGPU DRM support
DEPENDS:=@TARGET_x86 @DISPLAY_SUPPORT +kmod-backlight +kmod-drm-ttm \
+kmod-drm-ttm-helper +kmod-drm-kms-helper +kmod-i2c-algo-bit +amdgpu-firmware \
- +kmod-drm-display-helper +kmod-drm-buddy +kmod-acpi-video
+ +kmod-drm-display-helper +kmod-drm-buddy +kmod-acpi-video \
+ +LINUX_6_6:kmod-drm-exec +LINUX_6_6:kmod-drm-suballoc-helper
KCONFIG:=CONFIG_DRM_AMDGPU \
CONFIG_DRM_AMDGPU_SI=y \
CONFIG_DRM_AMDGPU_CIK=y \
@@ -475,7 +476,7 @@ define KernelPackage/drm-radeon
TITLE:=Radeon DRM support
DEPENDS:=@TARGET_x86 @DISPLAY_SUPPORT +kmod-backlight +kmod-drm-kms-helper \
+kmod-drm-ttm +kmod-drm-ttm-helper +kmod-i2c-algo-bit +radeon-firmware \
- +kmod-drm-display-helper +kmod-acpi-video
+ +kmod-drm-display-helper +kmod-acpi-video +LINUX_6_6:kmod-drm-suballoc-helper
KCONFIG:=CONFIG_DRM_RADEON
FILES:=$(LINUX_DIR)/drivers/gpu/drm/radeon/radeon.ko
AUTOLOAD:=$(call AutoProbe,radeon)