summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2022-05-16 16:14:41 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-06-19 12:31:02 +0200
commit9379bc2fcf905568ef329a121c8c8a11fc98b02c (patch)
tree3a11966770c08161f653f5554af8c4a21ea2f702
parentadbdfc9366fed2d28dbd36883ddbdb566a313f71 (diff)
downloadopenwrt-9379bc2fcf905568ef329a121c8c8a11fc98b02c.tar.gz
openwrt-9379bc2fcf905568ef329a121c8c8a11fc98b02c.tar.bz2
openwrt-9379bc2fcf905568ef329a121c8c8a11fc98b02c.zip
netfilter: kmod-nft-xfrm
Add kmod-nft-xfrm package. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
-rw-r--r--include/netfilter.mk2
-rw-r--r--package/kernel/linux/modules/netfilter.mk11
2 files changed, 13 insertions, 0 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index e49725fd31..50a002be65 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -361,6 +361,8 @@ $(eval $(if $(NF_KMOD),$(call nf_add,NFT_TPROXY,CONFIG_NFT_TPROXY, $(P_XT)nft_tp
$(eval $(if $(NF_KMOD),$(call nf_add,NFT_COMPAT,CONFIG_NFT_COMPAT, $(P_XT)nft_compat),))
+$(eval $(if $(NF_KMOD),$(call nf_add,NFT_XFRM,CONFIG_NFT_XFRM, $(P_XT)nft_xfrm),))
+
# userland only
IPT_BUILTIN += $(NF_IPT-y) $(NF_IPT-m)
IPT_BUILTIN += $(IPT_CORE-y) $(IPT_CORE-m)
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index cf2fccec05..6b9d620c55 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -1272,3 +1272,14 @@ define KernelPackage/nft-compat
endef
$(eval $(call KernelPackage,nft-compat))
+
+define KernelPackage/nft-xfrm
+ SUBMENU:=$(NF_MENU)
+ TITLE:=Netfilter nf_tables xfrm support (ipsec)
+ DEPENDS:=+kmod-nft-core
+ FILES:=$(foreach mod,$(NFT_XFRM-m),$(LINUX_DIR)/net/$(mod).ko)
+ AUTOLOAD:=$(call AutoProbe,$(notdir $(NFT_XFRM-m)))
+ KCONFIG:=$(KCONFIG_NFT_XFRM)
+endef
+
+$(eval $(call KernelPackage,nft-xfrm))