summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-04 11:14:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-04 11:14:08 +0000
commit9abbe7a03331e090354effabae026992dc962332 (patch)
tree81a84364087dfcdbdf390d024d3037d8bb1455d1
parentf082d1fddf936c406eed2eeeeef89972cf64bd22 (diff)
downloadopenwrt-9abbe7a03331e090354effabae026992dc962332.tar.gz
openwrt-9abbe7a03331e090354effabae026992dc962332.tar.bz2
openwrt-9abbe7a03331e090354effabae026992dc962332.zip
Rename 'refresh' to 'update' and make the new 'refresh' actually refresh all the patches. Also added a target package/refresh which will do this to all packages in the buildroot
SVN-Revision: 7488
-rw-r--r--include/quilt.mk12
-rw-r--r--package/Makefile11
-rw-r--r--target/Makefile2
-rw-r--r--target/linux/Makefile21
4 files changed, 23 insertions, 23 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index e8c3b90a68..53fb0a262b 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -34,6 +34,7 @@ ifneq ($(QUILT),)
endef
$(STAMP_CONFIGURED): $(STAMP_PATCHED)
prepare: $(STAMP_PATCHED)
+ quilt-check: $(STAMP_PATCHED)
else
define Build/Patch/Default
@if [ -d ./patches -a "$$$$(ls ./patches | wc -l)" -gt 0 ]; then \
@@ -82,7 +83,7 @@ define Quilt/Refresh/Kernel
$(call Quilt/RefreshDir,./patches,platform/)
endef
-refresh: $(STAMP_PREPARED)
+quilt-check: $(STAMP_PREPARED) FORCE
@[ -f "$(PKG_BUILD_DIR)/.quilt_used" ] || { \
echo "The source directory was not unpacked using quilt. Please rebuild with QUILT=1"; \
false; \
@@ -95,5 +96,14 @@ refresh: $(STAMP_PREPARED)
echo "The patches are not sorted in the right order. Please fix."; \
false; \
}
+
+refresh: quilt-check
+ @cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null
+ @cd $(PKG_BUILD_DIR); while quilt next 2>/dev/null >/dev/null && quilt push; do \
+ quilt refresh; \
+ done; ! quilt next 2>/dev/null >/dev/null
+ $(if $(KERNEL_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))
+
+update: quilt-check
$(if $(KERNEL_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))
diff --git a/package/Makefile b/package/Makefile
index 0713e8d23e..94241dbc3d 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -26,12 +26,16 @@ ifeq ($(QUIET),1)
%-compile %-install: FORCE
$(MAKE) -C $* $(patsubst $*-%,%,$@) || { $(call MESSAGE, "*** $* $(patsubst $*-%,%,$@) failed"); false; }
-%-prepare %-prereq %-download %-clean %-refresh: FORCE
+%-prepare %-prereq %-download %-clean: FORCE
else
-%-prepare %-prereq %-download %-clean %-compile %-install %-refresh: FORCE
+%-prepare %-prereq %-download %-clean %-compile %-install: FORCE
endif
$(MAKE) -C $* $(patsubst $*-%,%,$@)
+%-refresh %-update:
+ -$(MAKE) -C $* $(patsubst $*-%,%,$@)
+
+
# .IGNORE: $(COMPILE_PACKAGES)
$(TMP_DIR)/.packagedeps: $(TMP_DIR)/.packageinfo
@@ -42,6 +46,9 @@ clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))
prereq: $(PREREQ_PACKAGES)
download: $(DOWNLOAD_PACKAGES)
compile: $(COMPILE_PACKAGES)
+ifneq ($(QUILT),)
+ refresh: $(patsubst %,%-refresh,$(package-y) $(package-m) $(package-))
+endif
install-targets: $(INSTALL_PACKAGES)
install:
diff --git a/target/Makefile b/target/Makefile
index 438d268b5e..a3b15b2659 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -51,5 +51,5 @@ image_install: image_compile
imagebuilder_install: image_install
$(MAKE) -C imagebuilder install
-%-prereq %-prepare %-download %-clean %-compile %-install %-refresh: FORCE
+%-prereq %-prepare %-download %-clean %-compile %-install %-refresh %-update: FORCE
$(MAKE) -C $* $(patsubst $*-%,%,$@)
diff --git a/target/linux/Makefile b/target/linux/Makefile
index 275085448f..e124869150 100644
--- a/target/linux/Makefile
+++ b/target/linux/Makefile
@@ -7,23 +7,6 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/target.mk
-download:
- $(MAKE) -C $(BOARD)-$(KERNEL) download
+clean download prepare compile install menuconfig update refresh: FORCE
+ $(MAKE) -C $(BOARD)-$(KERNEL) $@
-prepare:
- $(MAKE) -C $(BOARD)-$(KERNEL) prepare
-
-compile:
- $(MAKE) -C $(BOARD)-$(KERNEL) compile
-
-install:
- $(MAKE) -C $(BOARD)-$(KERNEL) install
-
-refresh:
- $(MAKE) -C $(BOARD)-$(KERNEL) refresh
-
-menuconfig:
- $(MAKE) -C $(BOARD)-$(KERNEL) menuconfig
-
-clean:
- $(MAKE) -C $(BOARD)-$(KERNEL) clean