summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLech Perczak <lech.perczak@gmail.com>2022-08-10 01:10:57 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-08-13 20:52:37 +0200
commit9f5cbb6e8b9537942db405719bf7662d0e08b8c5 (patch)
treed4d5236a51a617edcf38be73572f887f939c0828
parent611291383a826827f240eddebca1949c2e1e7115 (diff)
downloadopenwrt-9f5cbb6e8b9537942db405719bf7662d0e08b8c5.tar.gz
openwrt-9f5cbb6e8b9537942db405719bf7662d0e08b8c5.tar.bz2
openwrt-9f5cbb6e8b9537942db405719bf7662d0e08b8c5.zip
ath25: fix initramfs image generation
Commit 21f460a5dbef ("ath25: fix duplicate LZMA compression") changed the way kernel images are generated, affecting initramfs images instead. Initramfs images were previously ELF images, and by mistake this change caused the raw kernel image to be used as a source. This caused them to be non-loadable by bootloaders. Restore the previous KERNEL_INITRAMFS recipe and adjust KERNEL_INITRAMFS_NAME to point at the correct source artifact. While at that, adjust KERNEL_INITRAMFS_SUFFIX to -kernel.elf, so it matches the suffix of non-initramfs kernel artifact. Fixes: 21f460a5dbef ("ath25: fix duplicate LZMA compression") Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
-rw-r--r--target/linux/ath25/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ath25/image/Makefile b/target/linux/ath25/image/Makefile
index d6cd53d261..9cdcdf9e95 100644
--- a/target/linux/ath25/image/Makefile
+++ b/target/linux/ath25/image/Makefile
@@ -54,6 +54,9 @@ endef
define Device/Default
PROFILES = Default $$(DEVICE_NAME)
KERNEL := copy-kernel | lzma-kernel
+ KERNEL_INITRAMFS = kernel-bin
+ KERNEL_INITRAMFS_NAME := vmlinux-initramfs.elf
+ KERNEL_INITRAMFS_SUFFIX := -kernel.elf
IMAGES := sysupgrade.bin
FILESYSTEMS := squashfs
endef