summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLech Perczak <lech.perczak@gmail.com>2024-10-02 16:23:13 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2024-10-22 00:39:32 +0200
commita69eaf80796fda2df7bbae74af62e700000aff19 (patch)
tree4ae4811c2c877a61078a9007fb10d345d5daffa9
parent64424c24275bf254cc515197b14da165255b8830 (diff)
downloadopenwrt-a69eaf80796fda2df7bbae74af62e700000aff19.tar.gz
openwrt-a69eaf80796fda2df7bbae74af62e700000aff19.tar.bz2
openwrt-a69eaf80796fda2df7bbae74af62e700000aff19.zip
bcm53xx: enable CONFIG_I2C_BCM_IPROC
This is required for the AT24 EEPROM holding MAC address on Meraki devices to probe before preinit starts, so all network devices can be available at the preinit network setup starts Signed-off-by: Lech Perczak <lech.perczak@gmail.com> Link: https://github.com/openwrt/openwrt/pull/16634 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--target/linux/bcm53xx/config-6.64
-rw-r--r--target/linux/bcm53xx/image/Makefile6
2 files changed, 6 insertions, 4 deletions
diff --git a/target/linux/bcm53xx/config-6.6 b/target/linux/bcm53xx/config-6.6
index 26fa023595..e9ac56416a 100644
--- a/target/linux/bcm53xx/config-6.6
+++ b/target/linux/bcm53xx/config-6.6
@@ -183,6 +183,9 @@ CONFIG_HW_RANDOM=y
CONFIG_HW_RANDOM_BCM2835=y
CONFIG_HZ_FIXED=0
CONFIG_HZ_PERIODIC=y
+CONFIG_I2C=y
+CONFIG_I2C_BCM_IPROC=y
+# CONFIG_I2C_SLAVE_TESTUNIT is not set
CONFIG_INITRAMFS_SOURCE=""
CONFIG_IRQCHIP=y
CONFIG_IRQSTACKS=y
@@ -294,6 +297,7 @@ CONFIG_PWM_SYSFS=y
CONFIG_RANDSTRUCT_NONE=y
CONFIG_RATIONAL=y
CONFIG_REGMAP=y
+CONFIG_REGMAP_I2C=y
CONFIG_REGMAP_MMIO=y
CONFIG_RFS_ACCEL=y
CONFIG_RPS=y
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 501486c063..8318450293 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -382,8 +382,7 @@ TARGET_DEVICES += luxul_xwr-3150
define Device/meraki_mr26
DEVICE_VENDOR := Meraki
DEVICE_MODEL := MR26
- DEVICE_PACKAGES := $(B43) kmod-i2c-bcm-iproc \
- kmod-hwmon-ina2xx kmod-leds-uleds nu801
+ DEVICE_PACKAGES := $(B43) kmod-hwmon-ina2xx kmod-leds-uleds nu801
DEVICE_DTS := bcm53015-meraki-mr26
# resize the initramfs to fit the size of the existing part.safe.
KERNEL_LOADADDR := 0x00008000
@@ -399,8 +398,7 @@ TARGET_DEVICES += meraki_mr26
define Device/meraki_mr32
DEVICE_VENDOR := Meraki
DEVICE_MODEL := MR32
- DEVICE_PACKAGES := $(B43) kmod-i2c-bcm-iproc \
- kmod-leds-pwm kmod-hwmon-ina2xx kmod-bluetooth
+ DEVICE_PACKAGES := $(B43) kmod-leds-pwm kmod-hwmon-ina2xx kmod-bluetooth
DEVICE_DTS := bcm53016-meraki-mr32
# Meraki FW r23 tries to resize the part.safe partition before it will
# flash the image. This is a bit of a problem, since resizing will fail