summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2022-08-07 14:06:14 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-08-10 21:36:17 +0200
commitb75425370d8de747457c137463bc4d15f6f44d00 (patch)
tree1db88bf620cf2240e46c5be949b81d01b0089821
parent5808973d141f488e06efe4749dbf651565fd5510 (diff)
downloadopenwrt-b75425370d8de747457c137463bc4d15f6f44d00.tar.gz
openwrt-b75425370d8de747457c137463bc4d15f6f44d00.tar.bz2
openwrt-b75425370d8de747457c137463bc4d15f6f44d00.zip
kernel: kmod-nft-nat6: Remove package
The nft NAT packages for IPv4 and IPv6 were merged into the common packages with kernel 5.1. The kmod-nft-nat6 package was empty in our build, remove it. Multiple kernel configuration options were also removed, remove them from our generic kernel configuration too. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--include/netfilter.mk5
-rw-r--r--package/kernel/linux/modules/netfilter.mk11
-rw-r--r--package/network/config/firewall4/Makefile2
-rw-r--r--target/linux/generic/config-5.103
-rw-r--r--target/linux/generic/config-5.153
5 files changed, 1 insertions, 23 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 50a002be65..657b4d9d39 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -341,12 +341,7 @@ $(eval $(if $(NF_KMOD),$(call nf_add,NFT_BRIDGE,CONFIG_NF_CONNTRACK_BRIDGE, $(P_
$(eval $(if $(NF_KMOD),$(call nf_add,NFT_NAT,CONFIG_NFT_NAT, $(P_XT)nft_nat),))
$(eval $(if $(NF_KMOD),$(call nf_add,NFT_NAT,CONFIG_NFT_NAT, $(P_XT)nft_chain_nat),))
-$(eval $(if $(NF_KMOD),$(call nf_add,NFT_NAT,CONFIG_NFT_REDIR_IPV4, $(P_V4)nft_redir_ipv4),))
$(eval $(if $(NF_KMOD),$(call nf_add,NFT_NAT,CONFIG_NFT_MASQ, $(P_XT)nft_masq),))
-$(eval $(if $(NF_KMOD),$(call nf_add,NFT_NAT,CONFIG_NFT_MASQ_IPV4, $(P_V4)nft_masq_ipv4),))
-
-$(eval $(if $(NF_KMOD),$(call nf_add,NFT_NAT6,CONFIG_NFT_REDIR_IPV6, $(P_V6)nft_redir_ipv6),))
-$(eval $(if $(NF_KMOD),$(call nf_add,NFT_NAT6,CONFIG_NFT_MASQ_IPV6, $(P_V6)nft_masq_ipv6),))
$(eval $(if $(NF_KMOD),$(call nf_add,NFT_FIB,CONFIG_NFT_FIB, $(P_XT)nft_fib),))
$(eval $(if $(NF_KMOD),$(call nf_add,NFT_FIB,CONFIG_NFT_FIB_INET, $(P_XT)nft_fib_inet),))
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index 22b7dbd285..d68a2d068a 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -1185,17 +1185,6 @@ endef
$(eval $(call KernelPackage,nft-offload))
-define KernelPackage/nft-nat6
- SUBMENU:=$(NF_MENU)
- TITLE:=Netfilter nf_tables IPv6-NAT support
- DEPENDS:=+kmod-nft-nat +kmod-nf-nat6
- FILES:=$(foreach mod,$(NFT_NAT6-m),$(LINUX_DIR)/net/$(mod).ko)
- AUTOLOAD:=$(call AutoProbe,$(notdir $(NFT_NAT6-m)))
- KCONFIG:=$(KCONFIG_NFT_NAT6)
-endef
-
-$(eval $(call KernelPackage,nft-nat6))
-
define KernelPackage/nft-netdev
SUBMENU:=$(NF_MENU)
TITLE:=Netfilter nf_tables netdev support
diff --git a/package/network/config/firewall4/Makefile b/package/network/config/firewall4/Makefile
index d6f363f3c8..0003fc09c3 100644
--- a/package/network/config/firewall4/Makefile
+++ b/package/network/config/firewall4/Makefile
@@ -23,7 +23,7 @@ define Package/firewall4
TITLE:=OpenWrt 4th gen firewall
DEPENDS:= \
+kmod-nft-core +kmod-nft-fib +kmod-nft-offload \
- +kmod-nft-nat +kmod-nft-nat6 \
+ +kmod-nft-nat \
+nftables-json \
+ucode +ucode-mod-fs +ucode-mod-ubus +ucode-mod-uci
EXTRA_DEPENDS:=ucode (>= 2022-03-22)
diff --git a/target/linux/generic/config-5.10 b/target/linux/generic/config-5.10
index 0ddd2a50bc..3d04a17243 100644
--- a/target/linux/generic/config-5.10
+++ b/target/linux/generic/config-5.10
@@ -4134,10 +4134,7 @@ CONFIG_NF_CONNTRACK_PROCFS=y
# CONFIG_NF_NAT_AMANDA is not set
# CONFIG_NF_NAT_FTP is not set
# CONFIG_NF_NAT_H323 is not set
-# CONFIG_NF_NAT_IPV6 is not set
# CONFIG_NF_NAT_IRC is not set
-CONFIG_NF_NAT_MASQUERADE_IPV4=y
-CONFIG_NF_NAT_MASQUERADE_IPV6=y
# CONFIG_NF_NAT_NEEDED is not set
# CONFIG_NF_NAT_PPTP is not set
# CONFIG_NF_NAT_PROTO_GRE is not set
diff --git a/target/linux/generic/config-5.15 b/target/linux/generic/config-5.15
index e38d9dd80f..6323543991 100644
--- a/target/linux/generic/config-5.15
+++ b/target/linux/generic/config-5.15
@@ -4294,10 +4294,7 @@ CONFIG_NF_CONNTRACK_PROCFS=y
# CONFIG_NF_NAT_AMANDA is not set
# CONFIG_NF_NAT_FTP is not set
# CONFIG_NF_NAT_H323 is not set
-# CONFIG_NF_NAT_IPV6 is not set
# CONFIG_NF_NAT_IRC is not set
-CONFIG_NF_NAT_MASQUERADE_IPV4=y
-CONFIG_NF_NAT_MASQUERADE_IPV6=y
# CONFIG_NF_NAT_NEEDED is not set
# CONFIG_NF_NAT_PPTP is not set
# CONFIG_NF_NAT_PROTO_GRE is not set