summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2023-06-29 14:29:02 +0200
committerPetr Štetiar <ynezz@true.cz>2023-07-28 08:19:18 +0200
commitba415af5706f0369e4d299e4dfe50541a4a8056b (patch)
tree41617de9d0c822ea0d0cc523fa9fe32c25ed46c7
parentdcdcfc15115a1038e90f21f5aa41726d9c7e2fe5 (diff)
downloadopenwrt-ba415af5706f0369e4d299e4dfe50541a4a8056b.tar.gz
openwrt-ba415af5706f0369e4d299e4dfe50541a4a8056b.tar.bz2
openwrt-ba415af5706f0369e4d299e4dfe50541a4a8056b.zip
ipq807x: prpl-haze: fix sysupgrade flashing from bootloader
While flashing sysupgrade image from U-Boot, then the rootfs_data overlay filesystem formatting is left for the fstools during firstboot, but that wont work as mkfs.f2fs is missing in the sysupgrade image: mount_root: overlay filesystem in /dev/loop0 has not been formatted yet mount_root: no usable overlay filesystem found, using tmpfs overlay sh: mkfs.f2fs: not found Filesystem Size Used Available Use% Mounted on /dev/loop0 139.6M 46.9M 92.6M 34% /overlay Number Start (sector) End (sector) Size Code Name 20 98850 406349 150.1 MiB FFFF rootfs So lets fix it by adding f2fs support to the sysupgrade image. Signed-off-by: Petr Štetiar <ynezz@true.cz>
-rw-r--r--target/linux/qualcommax/image/ipq807x.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/qualcommax/image/ipq807x.mk b/target/linux/qualcommax/image/ipq807x.mk
index 54f8caf5d7..555c723c5f 100644
--- a/target/linux/qualcommax/image/ipq807x.mk
+++ b/target/linux/qualcommax/image/ipq807x.mk
@@ -115,7 +115,8 @@ define Device/prpl_haze
DEVICE_MODEL := Haze
DEVICE_DTS_CONFIG := config@hk09
SOC := ipq8072
- DEVICE_PACKAGES += ath11k-firmware-qcn9074 ipq-wifi-prpl_haze kmod-ath11k-pci
+ DEVICE_PACKAGES += ath11k-firmware-qcn9074 ipq-wifi-prpl_haze kmod-ath11k-pci \
+ mkf2fs f2fsck kmod-fs-f2fs
endef
TARGET_DEVICES += prpl_haze