summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2024-05-20 18:08:28 +0300
committerPaul Spooren <mail@aparcar.org>2024-05-20 18:08:28 +0300
commitc1e0f99ef8066b4a5032409b7e81516fed166008 (patch)
tree7fa8efa282be2734139d73c159ebd4db4ae69b7c
parent2b8e875a85802f6281df134e2231308f6c928796 (diff)
downloadopenwrt-c1e0f99ef8066b4a5032409b7e81516fed166008.tar.gz
openwrt-c1e0f99ef8066b4a5032409b7e81516fed166008.tar.bz2
openwrt-c1e0f99ef8066b4a5032409b7e81516fed166008.zip
apk: disable rootfs repositories during build
Since we set the root for APK it tries to use those during the build, which shouldn't happen since local package are used instead. Disable the repositories by manually setting an empty repository. Signed-off-by: Paul Spooren <mail@aparcar.org>
-rw-r--r--include/rootfs.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/rootfs.mk b/include/rootfs.mk
index c2a32fa102..9fb7d8cfdf 100644
--- a/include/rootfs.mk
+++ b/include/rootfs.mk
@@ -47,6 +47,7 @@ apk = \
IPKG_INSTROOT=$(1) \
$(FAKEROOT) $(STAGING_DIR_HOST)/bin/apk \
--root $(1) \
+ --repositories-file /dev/zero \
--keys-dir $(TOPDIR) \
--no-cache \
--no-logfile \