summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jonas.gorski@gmail.com>2023-07-06 21:01:06 +0200
committerJonas Gorski <jonas.gorski@gmail.com>2023-07-06 21:03:11 +0200
commitc22931b653633f368569f638258b41df7943f14a (patch)
tree4159655e8023b7c9f2f5432aefcfc67426343d2d
parenta20735da211930a50330725d5f0b29f81b2a0b9c (diff)
downloadopenwrt-c22931b653633f368569f638258b41df7943f14a.tar.gz
openwrt-c22931b653633f368569f638258b41df7943f14a.tar.bz2
openwrt-c22931b653633f368569f638258b41df7943f14a.zip
kernel-headers: install isa-rev.h on mips to fix lzma-lader on linux 6.1
Since kernel 5.17+ the mips asm.h includes isa-rev.h, which itself was added 4.17. Without it, lzma-loader will fail to build: make[3] -C target/linux compile make[5]: warning: jobserver unavailable: using -j1. Add '+' to parent make rule. In file included from head.S:22: .../staging_dir/toolchain-mips_mips32_gcc-12.3.0_musl/include/asm/asm.h:22:10: fatal error: asm/isa-rev.h: No such file or directory 22 | #include <asm/isa-rev.h> | ^~~~~~~~~~~~~~~ compilation terminated. make[6]: *** [Makefile:64: head.o] Error 1 make[5]: *** [Makefile:345: compile] Error 2 make[4]: *** [Makefile:24: compile] Error 2 make[3]: *** [Makefile:11: compile] Error 2 ERROR: target/linux failed to build. So add the file to the files to install. We can do that unconditionally, since the oldest supported kernel 5.15 already includes it, even it if does not need it. Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
-rw-r--r--toolchain/kernel-headers/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/toolchain/kernel-headers/Makefile b/toolchain/kernel-headers/Makefile
index eea0ffbde0..c1a8710a4f 100644
--- a/toolchain/kernel-headers/Makefile
+++ b/toolchain/kernel-headers/Makefile
@@ -68,6 +68,7 @@ ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
$(HOST_BUILD_DIR)/arch/mips/include/asm/asm.h \
$(HOST_BUILD_DIR)/arch/mips/include/asm/regdef.h \
$(HOST_BUILD_DIR)/arch/mips/include/asm/asm-eva.h \
+ $(HOST_BUILD_DIR)/arch/mips/include/asm/isa-rev.h \
$(BUILD_DIR_TOOLCHAIN)/linux-dev/include/asm/
endef
endif