summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2017-01-27 15:18:00 +0100
committerStijn Tintel <stijn@linux-ipv6.be>2017-02-06 20:13:06 +0100
commitc656cbc56bba7ab0b2cfd8d850707bc60b7f6efe (patch)
treef4e108f4afcd690f86da76ebf448e52c1fd1cd33
parentee3067c588139ef60a72f5fecac979580d3651e3 (diff)
downloadopenwrt-c656cbc56bba7ab0b2cfd8d850707bc60b7f6efe.tar.gz
openwrt-c656cbc56bba7ab0b2cfd8d850707bc60b7f6efe.tar.bz2
openwrt-c656cbc56bba7ab0b2cfd8d850707bc60b7f6efe.zip
kernel: bump to 4.4.45
Refreshed patches for all supported targets. Compiled & tested on cns3xxx & imx6 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com> (cherry picked from commit 4d1515070baeca64fedaca957b6b4156976f3b3a) Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Conflicts: target/linux/ar71xx/patches-4.4/920-usb-chipidea-AR933x-platform-support.patch
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/cns3xxx/patches-4.4/130-Extend-PCIE_BUS_PEER2PEER-to-set-MRSS-128-to-fix-CNS3xxx-BM-DMA..patch2
-rw-r--r--target/linux/cns3xxx/patches-4.4/200-broadcom_phy_reinit.patch4
3 files changed, 5 insertions, 5 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 199c2adb58..b1452524f4 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -3,10 +3,10 @@
LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .43
-LINUX_VERSION-4.4 = .44
+LINUX_VERSION-4.4 = .45
LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
-LINUX_KERNEL_HASH-4.4.44 = fabdcf2703f22a5b8aa3a3407909f18fdeea610c3d0f418fdc29123ed04de748
+LINUX_KERNEL_HASH-4.4.45 = 22fb59247746a3dd109df6d1485a9972382507a3c0040ac33371b3fd2a021741
ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
diff --git a/target/linux/cns3xxx/patches-4.4/130-Extend-PCIE_BUS_PEER2PEER-to-set-MRSS-128-to-fix-CNS3xxx-BM-DMA..patch b/target/linux/cns3xxx/patches-4.4/130-Extend-PCIE_BUS_PEER2PEER-to-set-MRSS-128-to-fix-CNS3xxx-BM-DMA..patch
index c58830ac6f..db2c29fc92 100644
--- a/target/linux/cns3xxx/patches-4.4/130-Extend-PCIE_BUS_PEER2PEER-to-set-MRSS-128-to-fix-CNS3xxx-BM-DMA..patch
+++ b/target/linux/cns3xxx/patches-4.4/130-Extend-PCIE_BUS_PEER2PEER-to-set-MRSS-128-to-fix-CNS3xxx-BM-DMA..patch
@@ -1,6 +1,6 @@
--- a/drivers/pci/probe.c
+++ b/drivers/pci/probe.c
-@@ -1964,7 +1964,8 @@ static void pcie_write_mrrs(struct pci_d
+@@ -1966,7 +1966,8 @@ static void pcie_write_mrrs(struct pci_d
/* In the "safe" case, do not configure the MRRS. There appear to be
* issues with setting MRRS to 0 on a number of devices.
*/
diff --git a/target/linux/cns3xxx/patches-4.4/200-broadcom_phy_reinit.patch b/target/linux/cns3xxx/patches-4.4/200-broadcom_phy_reinit.patch
index 1c7215051d..0d8ff5997b 100644
--- a/target/linux/cns3xxx/patches-4.4/200-broadcom_phy_reinit.patch
+++ b/target/linux/cns3xxx/patches-4.4/200-broadcom_phy_reinit.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/broadcom.c
+++ b/drivers/net/phy/broadcom.c
-@@ -332,6 +332,11 @@ static int bcm5481_config_aneg(struct ph
+@@ -362,6 +362,11 @@ static int bcm5481_config_aneg(struct ph
/* Write bits 14:0. */
reg |= (1 << 15);
phy_write(phydev, 0x18, reg);
@@ -11,4 +11,4 @@
+ phy_write(phydev, 0x1c, 0xa41f);
}
- return ret;
+ if (of_property_read_bool(np, "enet-phy-lane-swap")) {