summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-07-14 22:10:37 +0200
committerPetr Štetiar <ynezz@true.cz>2019-07-15 00:38:24 +0200
commitcbae306815bdfc335eeedc35dc5df3d2d4021a2a (patch)
tree6b84af0479ae5193ff62a69787207632070c2a1d
parentcb3cd526948af3f69da1af18e035177a0a8f58e3 (diff)
downloadopenwrt-cbae306815bdfc335eeedc35dc5df3d2d4021a2a.tar.gz
openwrt-cbae306815bdfc335eeedc35dc5df3d2d4021a2a.tar.bz2
openwrt-cbae306815bdfc335eeedc35dc5df3d2d4021a2a.zip
fstools: add direct dependencies on libblobmsg-json and libjson-c
The OpenWrt buildroot ABI version rebuild tracker does not handle transient dependencies, therefore add all libraries linked by block-mount and blockd as direct dependencies to the corresponding binary package definition. This ensures that block-mount and blockd is automatically rebuilt and relinked if any of these libraries has its ABI_VERSION updated in the future. Fixes: FS#2373 [jow: similar fix for procd and 98.42% of commit message] Signed-off-by: Jo-Philip Wich <jow@mein.io> Signed-off-by: Petr Štetiar <ynezz@true.cz>
-rw-r--r--package/system/fstools/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/system/fstools/Makefile b/package/system/fstools/Makefile
index 3aa250f7d4..4bc59150da 100644
--- a/package/system/fstools/Makefile
+++ b/package/system/fstools/Makefile
@@ -79,14 +79,14 @@ define Package/block-mount
SECTION:=base
CATEGORY:=Base system
TITLE:=Block device mounting and checking
- DEPENDS:=+ubox +libubox +libuci
+ DEPENDS:=+ubox +libubox +libuci +libblobmsg-json +libjson-c
endef
define Package/blockd
SECTION:=base
CATEGORY:=Base system
TITLE:=Block device automounting
- DEPENDS:=+block-mount +fstools +libubus +kmod-fs-autofs4
+ DEPENDS:=+block-mount +fstools +libubus +kmod-fs-autofs4 +libblobmsg-json +libjson-c
endef
define Package/fstools/install