summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2024-04-15 21:08:06 -0400
committerRobert Marko <robimarko@gmail.com>2024-04-25 21:33:51 +0200
commitcdd56fc8934142a7df68118830611617ddb5e8fc (patch)
tree0c1cabc79d44a811d0a24678987bd92e271fa818
parent5a028a8d737b669d0d30d1ef93981e10f585a0e7 (diff)
downloadopenwrt-cdd56fc8934142a7df68118830611617ddb5e8fc.tar.gz
openwrt-cdd56fc8934142a7df68118830611617ddb5e8fc.tar.bz2
openwrt-cdd56fc8934142a7df68118830611617ddb5e8fc.zip
tools/missing-macros: add symlinks to makeinfo
There are other wrapper scripts released with makeinfo like texi2pdf which are required by the build prerequisites of some tools, and have a similar purpose and usage. Let the makeinfo perl script handle all of these cases. It's worth mentioning that "texi2any" is the actual program and "makeinfo" is one of it's aliases. From upstream GNU: makeinfo: texi2any rm -f $@ -$(LN_S) texi2any $@ Signed-off-by: Michael Pratt <mcpratt@pm.me> Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
-rw-r--r--tools/missing-macros/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/tools/missing-macros/Makefile b/tools/missing-macros/Makefile
index 1e423621bd..edbcb84302 100644
--- a/tools/missing-macros/Makefile
+++ b/tools/missing-macros/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=missing-macros
-PKG_RELEASE:=11
+PKG_RELEASE:=12
include $(INCLUDE_DIR)/host-build.mk
@@ -23,6 +23,11 @@ define Host/Install
$(INSTALL_DATA) ./src/m4/*.m4 $(STAGING_DIR_HOST)/share/aclocal/
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
$(INSTALL_BIN) ./src/bin/* $(STAGING_DIR_HOST)/bin/
+ $(LN) makeinfo $(STAGING_DIR_HOST)/bin/texi2any
+ $(LN) makeinfo $(STAGING_DIR_HOST)/bin/texi2pdf
+ $(LN) makeinfo $(STAGING_DIR_HOST)/bin/texi2dvi
+ $(LN) makeinfo $(STAGING_DIR_HOST)/bin/pdftexi2dvi
+ $(LN) makeinfo $(STAGING_DIR_HOST)/bin/texi2html
endef
$(eval $(call HostBuild))