summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@citymesh.com>2023-09-20 15:02:40 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-10-06 21:53:13 +0200
commitd382756b851571e13d1d97cf29de697385e6bfff (patch)
tree4f72082a39dec645721de1c0e8e31c4b8b832ec3
parent79ba851a8aabab9a21a9dec373f5559cce87f88c (diff)
downloadopenwrt-d382756b851571e13d1d97cf29de697385e6bfff.tar.gz
openwrt-d382756b851571e13d1d97cf29de697385e6bfff.tar.bz2
openwrt-d382756b851571e13d1d97cf29de697385e6bfff.zip
ath79: mikrotik: fix build error with kernel 6.1
drivers/mfd/rb4xx-cpld.c:167:19: error: initialization of 'void (*)(struct spi_device *)' from incompatible pointer type 'int (*)(struct spi_device *)' [-Werror=incompatible-pointer-types] 167 | .remove = rb4xx_cpld_remove, | ^~~~~~~~~~~~~~~~~ drivers/mfd/rb4xx-cpld.c:167:19: note: (near initialization for 'rb4xx_cpld_driver.remove') cc1: some warnings being treated as errors make[8]: *** [scripts/Makefile.build:250: drivers/mfd/rb4xx-cpld.o] Error 1 make[7]: *** [scripts/Makefile.build:500: drivers/mfd] Error 2 make[6]: *** [scripts/Makefile.build:500: drivers] Error 2 make[5]: *** [Makefile:2012: .] Error 2 As the allocated function does nothing, simply delete it. Signed-off-by: Koen Vandeputte <koen.vandeputte@citymesh.com>
-rw-r--r--target/linux/ath79/files/drivers/mfd/rb4xx-cpld.c6
1 files changed, 0 insertions, 6 deletions
diff --git a/target/linux/ath79/files/drivers/mfd/rb4xx-cpld.c b/target/linux/ath79/files/drivers/mfd/rb4xx-cpld.c
index da18424c63..148157aa7b 100644
--- a/target/linux/ath79/files/drivers/mfd/rb4xx-cpld.c
+++ b/target/linux/ath79/files/drivers/mfd/rb4xx-cpld.c
@@ -151,11 +151,6 @@ static int rb4xx_cpld_probe(struct spi_device *spi)
NULL, 0, NULL);
}
-static int rb4xx_cpld_remove(struct spi_device *spi)
-{
- return 0;
-}
-
static const struct of_device_id rb4xx_cpld_dt_match[] = {
{ .compatible = "mikrotik,rb4xx-cpld", },
{ },
@@ -164,7 +159,6 @@ MODULE_DEVICE_TABLE(of, rb4xx_cpld_dt_match);
static struct spi_driver rb4xx_cpld_driver = {
.probe = rb4xx_cpld_probe,
- .remove = rb4xx_cpld_remove,
.driver = {
.name = "rb4xx-cpld",
.bus = &spi_bus_type,