summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThorsten Glaser <tg@mirbsd.org>2018-10-22 19:28:50 +0200
committerJo-Philipp Wich <jo@mein.io>2019-01-30 12:40:16 +0100
commitd4178c8f478c0e96ff22197b5174869721def831 (patch)
tree7c390dedb94a0ff2db51de36612339dd63ed8369
parentb98b55a64fb633d7901f9db5529e52e3175300e9 (diff)
downloadopenwrt-d4178c8f478c0e96ff22197b5174869721def831.tar.gz
openwrt-d4178c8f478c0e96ff22197b5174869721def831.tar.bz2
openwrt-d4178c8f478c0e96ff22197b5174869721def831.zip
build: fix umask detection bashism
the leading 0 is optional and not emitted by some shells Signed-off-by: Thorsten Glaser <tg@mirbsd.org> (cherry picked from commit da5bee5345ce8f66eb36b8993b87b684e5cce614)
-rw-r--r--include/prereq-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index a416a2d232..f7da916f64 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -24,7 +24,7 @@ $(eval $(call TestHostCommand,case-sensitive-fs, \
$(eval $(call TestHostCommand,proper-umask, \
Please build with umask 022 - other values produce broken packages, \
- umask | grep -xE 00[012][012]))
+ umask | grep -xE 0?0[012][012]))
$(eval $(call SetupHostCommand,gcc, \
Please install the GNU C Compiler (gcc) 4.8 or later, \