summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2024-04-08 03:54:13 -0400
committerRobert Marko <robimarko@gmail.com>2024-04-25 21:33:51 +0200
commitddb7177c57e1515d9b170a2a35c2d2f341311a05 (patch)
tree529a4c1f9abf2c9ad7dd084d4f34f07f92239d63
parent20ed56ec8b80936132d3dd66e3a7b82dd1d2ed89 (diff)
downloadopenwrt-ddb7177c57e1515d9b170a2a35c2d2f341311a05.tar.gz
openwrt-ddb7177c57e1515d9b170a2a35c2d2f341311a05.tar.bz2
openwrt-ddb7177c57e1515d9b170a2a35c2d2f341311a05.zip
tools/elfutils: remove no-op copy of tdestroy()
A false tdestroy() function was added in order to make elfutils build on macOS again. A previous commit added declarations for a real version of tdestroy() into gnulib, which is already imported, as well as the preprocessor flags and the triggers for the Makefile.am conditional in order to include the source to be built. Tested-by: Georgi Valkov <gvalkov@gmail.com> # MacOS Signed-off-by: Michael Pratt <mcpratt@pm.me> Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
-rw-r--r--tools/elfutils/patches/100-portability.patch14
1 files changed, 0 insertions, 14 deletions
diff --git a/tools/elfutils/patches/100-portability.patch b/tools/elfutils/patches/100-portability.patch
index 91fff1ca78..9a111c76d9 100644
--- a/tools/elfutils/patches/100-portability.patch
+++ b/tools/elfutils/patches/100-portability.patch
@@ -344,20 +344,6 @@
+{
+ return ppc_check_object_attribute(ebl, vendor, tag, value, tag_name, value_name);
+}
---- a/lib/libeu.h
-+++ b/lib/libeu.h
-@@ -45,4 +45,11 @@ extern char *xasprintf(const char *fmt,
- extern uint32_t crc32 (uint32_t crc, unsigned char *buf, size_t len);
- extern int crc32_file (int fd, uint32_t *resp);
-
-+#ifdef __APPLE__
-+static inline void tdestroy(void *root __attribute__ ((unused)),
-+ void (*freekey)(void *) __attribute__ ((unused)))
-+{
-+}
-+#endif
-+
- #endif
--- a/libdwfl/libdwflP.h
+++ b/libdwfl/libdwflP.h
@@ -31,6 +31,8 @@