summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2022-05-17 17:50:23 -0400
committerChristian Marangi <ansuelsmth@gmail.com>2024-01-05 16:25:13 +0100
commite4a43cda0efba562d0ed1973b584c21309040ccc (patch)
tree759d87762e373ba787b5ead7d2c3377c03bfff07
parent2e6ec200dfe6ee62380821bc001d0b546bc6f799 (diff)
downloadopenwrt-e4a43cda0efba562d0ed1973b584c21309040ccc.tar.gz
openwrt-e4a43cda0efba562d0ed1973b584c21309040ccc.tar.bz2
openwrt-e4a43cda0efba562d0ed1973b584c21309040ccc.zip
build: allow var.% targets to bypass the prepare steps
These targets are used to input variable values from the Make context into other things like python scripts, so log messages should be silenced and build prerequisites should be skipped. The same thing is done for the other variable print target "val.%". While at it, combine identical target rules into one definition. Signed-off-by: Michael Pratt <mcpratt@pm.me>
-rw-r--r--include/toplevel.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 328214be1b..96f32139d9 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -210,9 +210,7 @@ prereq:: prepare-tmpinfo .config
@+$(NO_TRACE_MAKE) -r -s $@
check: .config FORCE
- @+$(NO_TRACE_MAKE) -r -s $@ QUIET= V=s
-
-val.%: FORCE
+check val.% var.%: FORCE
@+$(NO_TRACE_MAKE) -r -s $@ QUIET= V=s
WARN_PARALLEL_ERROR = $(if $(BUILD_LOG),,$(and $(filter -j,$(MAKEFLAGS)),$(findstring s,$(OPENWRT_VERBOSE))))