summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-10-20 15:56:34 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-10-20 19:19:42 +0200
commite6281720f20b62a9c3fd3c3ae7ea23097da2e9ca (patch)
treec5e3e170dc86d3061895b7a7821d157643184b36
parent0be05de57756912973937b25e0b94f4e986bcb73 (diff)
downloadopenwrt-e6281720f20b62a9c3fd3c3ae7ea23097da2e9ca.tar.gz
openwrt-e6281720f20b62a9c3fd3c3ae7ea23097da2e9ca.tar.bz2
openwrt-e6281720f20b62a9c3fd3c3ae7ea23097da2e9ca.zip
kernel: fix missing regmap-mmio dependency for rtc-r7301
Add missing regmap-mmio dependency for rtc-r7301 to fix packaging error. Fixes: f2bc4c1f1588 ("kernel: Add kmod-rtc-r7301") Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
-rw-r--r--package/kernel/linux/modules/other.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index feee39602d..055dca6818 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -732,6 +732,7 @@ define KernelPackage/rtc-r7301
SUBMENU:=$(OTHER_MENU)
TITLE:=Epson RTC7301 support
DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
+ DEPENDS:=+kmod-regmap-mmio
KCONFIG:=CONFIG_RTC_DRV_R7301 \
CONFIG_RTC_CLASS=y
FILES:=$(LINUX_DIR)/drivers/rtc/rtc-r7301.ko