summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-08-30 12:47:44 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-08-30 13:07:40 +0200
commitf712db9df6320b296849378030a66372255ffca2 (patch)
treecc259f54ec6ca0973f17478cb7fcdca8268e730f
parent55840040dfcce33ca6a00da53f0345bd7e227cff (diff)
downloadopenwrt-f712db9df6320b296849378030a66372255ffca2.tar.gz
openwrt-f712db9df6320b296849378030a66372255ffca2.tar.bz2
openwrt-f712db9df6320b296849378030a66372255ffca2.zip
kernel: bump kernel 4.4 to version 4.4.153
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/cns3xxx/patches-4.4/130-Extend-PCIE_BUS_PEER2PEER-to-set-MRSS-128-to-fix-CNS3xxx-BM-DMA..patch2
-rw-r--r--target/linux/generic/patches-4.4/051-0001-ovl-rename-is_merge-to-is_lowest.patch8
-rw-r--r--target/linux/generic/patches-4.4/051-0002-ovl-override-creds-with-the-ones-from-the-superblock.patch10
-rw-r--r--target/linux/generic/patches-4.4/051-0005-ovl-proper-cleanup-of-workdir.patch12
-rw-r--r--target/linux/generic/patches-4.4/630-packet_socket_type.patch6
-rw-r--r--target/linux/mediatek/patches-4.4/0019-xhci-mediatek-support-MTK-xHCI-host-controller.patch4
-rw-r--r--target/linux/ramips/patches-4.4/0033-xhci-mediatek-support-MTK-xHCI-host-controller.patch4
8 files changed, 25 insertions, 25 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 44ad7c5666..e6df3393e8 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -3,10 +3,10 @@
LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .43
-LINUX_VERSION-4.4 = .151
+LINUX_VERSION-4.4 = .153
LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
-LINUX_KERNEL_HASH-4.4.151 = 5fea8c318626de61e99869eb6dde77e8af2419c5cf6f346280da4be1ab8089e8
+LINUX_KERNEL_HASH-4.4.153 = 0f2355515c22ca705600043bedc75218c68dcb8ab528f57f67851fbcb8545402
ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
diff --git a/target/linux/cns3xxx/patches-4.4/130-Extend-PCIE_BUS_PEER2PEER-to-set-MRSS-128-to-fix-CNS3xxx-BM-DMA..patch b/target/linux/cns3xxx/patches-4.4/130-Extend-PCIE_BUS_PEER2PEER-to-set-MRSS-128-to-fix-CNS3xxx-BM-DMA..patch
index b5306a7dbe..968f8514e6 100644
--- a/target/linux/cns3xxx/patches-4.4/130-Extend-PCIE_BUS_PEER2PEER-to-set-MRSS-128-to-fix-CNS3xxx-BM-DMA..patch
+++ b/target/linux/cns3xxx/patches-4.4/130-Extend-PCIE_BUS_PEER2PEER-to-set-MRSS-128-to-fix-CNS3xxx-BM-DMA..patch
@@ -1,6 +1,6 @@
--- a/drivers/pci/probe.c
+++ b/drivers/pci/probe.c
-@@ -1978,7 +1978,8 @@ static void pcie_write_mrrs(struct pci_d
+@@ -1982,7 +1982,8 @@ static void pcie_write_mrrs(struct pci_d
/* In the "safe" case, do not configure the MRRS. There appear to be
* issues with setting MRRS to 0 on a number of devices.
*/
diff --git a/target/linux/generic/patches-4.4/051-0001-ovl-rename-is_merge-to-is_lowest.patch b/target/linux/generic/patches-4.4/051-0001-ovl-rename-is_merge-to-is_lowest.patch
index 79140b9008..8ba4522bf2 100644
--- a/target/linux/generic/patches-4.4/051-0001-ovl-rename-is_merge-to-is_lowest.patch
+++ b/target/linux/generic/patches-4.4/051-0001-ovl-rename-is_merge-to-is_lowest.patch
@@ -26,7 +26,7 @@ Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
struct rb_root root;
struct list_head *list;
struct list_head middle;
-@@ -139,9 +139,9 @@ static int ovl_cache_entry_add_rb(struct
+@@ -140,9 +140,9 @@ static int ovl_cache_entry_add_rb(struct
return 0;
}
@@ -39,7 +39,7 @@ Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
{
struct ovl_cache_entry *p;
-@@ -193,10 +193,10 @@ static int ovl_fill_merge(struct dir_con
+@@ -194,10 +194,10 @@ static int ovl_fill_merge(struct dir_con
container_of(ctx, struct ovl_readdir_data, ctx);
rdd->count++;
@@ -52,7 +52,7 @@ Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
}
static int ovl_check_whiteouts(struct dentry *dir, struct ovl_readdir_data *rdd)
-@@ -289,7 +289,7 @@ static int ovl_dir_read_merged(struct de
+@@ -290,7 +290,7 @@ static int ovl_dir_read_merged(struct de
.ctx.actor = ovl_fill_merge,
.list = list,
.root = RB_ROOT,
@@ -61,7 +61,7 @@ Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
};
int idx, next;
-@@ -306,7 +306,7 @@ static int ovl_dir_read_merged(struct de
+@@ -307,7 +307,7 @@ static int ovl_dir_read_merged(struct de
* allows offsets to be reasonably constant
*/
list_add(&rdd.middle, rdd.list);
diff --git a/target/linux/generic/patches-4.4/051-0002-ovl-override-creds-with-the-ones-from-the-superblock.patch b/target/linux/generic/patches-4.4/051-0002-ovl-override-creds-with-the-ones-from-the-superblock.patch
index 208bc61ec5..2d40c7e86c 100644
--- a/target/linux/generic/patches-4.4/051-0002-ovl-override-creds-with-the-ones-from-the-superblock.patch
+++ b/target/linux/generic/patches-4.4/051-0002-ovl-override-creds-with-the-ones-from-the-superblock.patch
@@ -241,7 +241,7 @@ Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
bool is_lowest;
struct rb_root root;
struct list_head *list;
-@@ -205,17 +206,8 @@ static int ovl_check_whiteouts(struct de
+@@ -206,17 +207,8 @@ static int ovl_check_whiteouts(struct de
struct ovl_cache_entry *p;
struct dentry *dentry;
const struct cred *old_cred;
@@ -260,7 +260,7 @@ Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
err = mutex_lock_killable(&dir->d_inode->i_mutex);
if (!err) {
-@@ -231,7 +223,6 @@ static int ovl_check_whiteouts(struct de
+@@ -232,7 +224,6 @@ static int ovl_check_whiteouts(struct de
mutex_unlock(&dir->d_inode->i_mutex);
}
revert_creds(old_cred);
@@ -268,7 +268,7 @@ Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
return err;
}
-@@ -287,6 +278,7 @@ static int ovl_dir_read_merged(struct de
+@@ -288,6 +279,7 @@ static int ovl_dir_read_merged(struct de
struct path realpath;
struct ovl_readdir_data rdd = {
.ctx.actor = ovl_fill_merge,
@@ -309,7 +309,7 @@ Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
kfree(ufs);
}
-@@ -1087,10 +1097,14 @@ static int ovl_fill_super(struct super_b
+@@ -1107,10 +1117,14 @@ static int ovl_fill_super(struct super_b
else
sb->s_d_op = &ovl_dentry_operations;
@@ -325,7 +325,7 @@ Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
root_dentry = d_make_root(ovl_new_inode(sb, S_IFDIR, oe));
if (!root_dentry)
-@@ -1123,6 +1137,8 @@ static int ovl_fill_super(struct super_b
+@@ -1143,6 +1157,8 @@ static int ovl_fill_super(struct super_b
out_free_oe:
kfree(oe);
diff --git a/target/linux/generic/patches-4.4/051-0005-ovl-proper-cleanup-of-workdir.patch b/target/linux/generic/patches-4.4/051-0005-ovl-proper-cleanup-of-workdir.patch
index 7225fc8cd9..627e19ea96 100644
--- a/target/linux/generic/patches-4.4/051-0005-ovl-proper-cleanup-of-workdir.patch
+++ b/target/linux/generic/patches-4.4/051-0005-ovl-proper-cleanup-of-workdir.patch
@@ -33,10 +33,10 @@ Cc: <stable@vger.kernel.org>
--- a/fs/overlayfs/overlayfs.h
+++ b/fs/overlayfs/overlayfs.h
-@@ -164,6 +164,8 @@ extern const struct file_operations ovl_
- int ovl_check_empty_dir(struct dentry *dentry, struct list_head *list);
+@@ -165,6 +165,8 @@ int ovl_check_empty_dir(struct dentry *d
void ovl_cleanup_whiteouts(struct dentry *upper, struct list_head *list);
void ovl_cache_free(struct list_head *list);
+ int ovl_check_d_type_supported(struct path *realpath);
+void ovl_workdir_cleanup(struct inode *dir, struct vfsmount *mnt,
+ struct dentry *dentry, int level);
@@ -44,7 +44,7 @@ Cc: <stable@vger.kernel.org>
int ovl_setattr(struct dentry *dentry, struct iattr *attr);
--- a/fs/overlayfs/readdir.c
+++ b/fs/overlayfs/readdir.c
-@@ -247,7 +247,7 @@ static inline int ovl_dir_read(struct pa
+@@ -248,7 +248,7 @@ static inline int ovl_dir_read(struct pa
err = rdd->err;
} while (!err && rdd->count);
@@ -53,9 +53,9 @@ Cc: <stable@vger.kernel.org>
err = ovl_check_whiteouts(realpath->dentry, rdd);
fput(realfile);
-@@ -573,3 +573,64 @@ void ovl_cleanup_whiteouts(struct dentry
- }
- mutex_unlock(&upper->d_inode->i_mutex);
+@@ -610,3 +610,64 @@ int ovl_check_d_type_supported(struct pa
+
+ return rdd.d_type_supported;
}
+
+static void ovl_workdir_cleanup_recurse(struct path *path, int level)
diff --git a/target/linux/generic/patches-4.4/630-packet_socket_type.patch b/target/linux/generic/patches-4.4/630-packet_socket_type.patch
index dcd9928e7a..359b151020 100644
--- a/target/linux/generic/patches-4.4/630-packet_socket_type.patch
+++ b/target/linux/generic/patches-4.4/630-packet_socket_type.patch
@@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
if (!net_eq(dev_net(dev), sock_net(sk)))
goto drop;
-@@ -3137,6 +3139,7 @@ static int packet_create(struct net *net
+@@ -3139,6 +3141,7 @@ static int packet_create(struct net *net
mutex_init(&po->pg_vec_lock);
po->rollover = NULL;
po->prot_hook.func = packet_rcv;
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
if (sock->type == SOCK_PACKET)
po->prot_hook.func = packet_rcv_spkt;
-@@ -3795,6 +3798,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3797,6 +3800,16 @@ packet_setsockopt(struct socket *sock, i
po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
return 0;
}
@@ -108,7 +108,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
default:
return -ENOPROTOOPT;
}
-@@ -3847,6 +3860,13 @@ static int packet_getsockopt(struct sock
+@@ -3849,6 +3862,13 @@ static int packet_getsockopt(struct sock
case PACKET_VNET_HDR:
val = po->has_vnet_hdr;
break;
diff --git a/target/linux/mediatek/patches-4.4/0019-xhci-mediatek-support-MTK-xHCI-host-controller.patch b/target/linux/mediatek/patches-4.4/0019-xhci-mediatek-support-MTK-xHCI-host-controller.patch
index 31092b8488..cb91b13265 100644
--- a/target/linux/mediatek/patches-4.4/0019-xhci-mediatek-support-MTK-xHCI-host-controller.patch
+++ b/target/linux/mediatek/patches-4.4/0019-xhci-mediatek-support-MTK-xHCI-host-controller.patch
@@ -1487,7 +1487,7 @@ Reviewed-by: Daniel Thompson <daniel.thompson@linaro.org>
writel(temp, &xhci->ir_set->irq_control);
/* Set the HCD state before we enable the irqs */
-@@ -1725,6 +1730,9 @@ int xhci_drop_endpoint(struct usb_hcd *h
+@@ -1730,6 +1735,9 @@ int xhci_drop_endpoint(struct usb_hcd *h
xhci_endpoint_zero(xhci, xhci->devs[udev->slot_id], ep);
@@ -1497,7 +1497,7 @@ Reviewed-by: Daniel Thompson <daniel.thompson@linaro.org>
xhci_dbg(xhci, "drop ep 0x%x, slot id %d, new drop flags = %#x, new add flags = %#x\n",
(unsigned int) ep->desc.bEndpointAddress,
udev->slot_id,
-@@ -1820,6 +1828,15 @@ int xhci_add_endpoint(struct usb_hcd *hc
+@@ -1825,6 +1833,15 @@ int xhci_add_endpoint(struct usb_hcd *hc
return -ENOMEM;
}
diff --git a/target/linux/ramips/patches-4.4/0033-xhci-mediatek-support-MTK-xHCI-host-controller.patch b/target/linux/ramips/patches-4.4/0033-xhci-mediatek-support-MTK-xHCI-host-controller.patch
index 97eae37e5d..2493e20f93 100644
--- a/target/linux/ramips/patches-4.4/0033-xhci-mediatek-support-MTK-xHCI-host-controller.patch
+++ b/target/linux/ramips/patches-4.4/0033-xhci-mediatek-support-MTK-xHCI-host-controller.patch
@@ -1479,7 +1479,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
writel(temp, &xhci->ir_set->irq_control);
/* Set the HCD state before we enable the irqs */
-@@ -1725,6 +1730,9 @@ int xhci_drop_endpoint(struct usb_hcd *h
+@@ -1730,6 +1735,9 @@ int xhci_drop_endpoint(struct usb_hcd *h
xhci_endpoint_zero(xhci, xhci->devs[udev->slot_id], ep);
@@ -1489,7 +1489,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
xhci_dbg(xhci, "drop ep 0x%x, slot id %d, new drop flags = %#x, new add flags = %#x\n",
(unsigned int) ep->desc.bEndpointAddress,
udev->slot_id,
-@@ -1820,6 +1828,15 @@ int xhci_add_endpoint(struct usb_hcd *hc
+@@ -1825,6 +1833,15 @@ int xhci_add_endpoint(struct usb_hcd *hc
return -ENOMEM;
}