summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2021-06-15 09:54:45 +0200
committerJo-Philipp Wich <jo@mein.io>2021-06-15 09:58:33 +0200
commitfbb9b1f8ed0d8a76dd989cc6c16a4e0fda2b6e74 (patch)
treef86661c4a2d068ef76341e9fe164bd3d21c0b864
parent946019637ec9192450c685a61c589a9cbef7637b (diff)
downloadopenwrt-fbb9b1f8ed0d8a76dd989cc6c16a4e0fda2b6e74.tar.gz
openwrt-fbb9b1f8ed0d8a76dd989cc6c16a4e0fda2b6e74.tar.bz2
openwrt-fbb9b1f8ed0d8a76dd989cc6c16a4e0fda2b6e74.zip
build: ensure that dash isn't prepended twice to abi version suffix
The ABIV_$(pkgname) variable already is formatted so return it as-is from the GetABISuffix macro and only filter through FormatABISuffix if we read the raw ABI version value from a version stamp file. This ensures that binary intra-package dependencies on ABI versioned libraries are properly formatted. Ref: https://github.com/openwrt/packages/issues/15871 Fixes: f6a03bff5b ("build: prepend ABI suffixes with a dash if package name ends with digit") Signed-off-by: Jo-Philipp Wich <jo@mein.io>
-rw-r--r--include/feeds.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index e499ac2684..632fecb4a3 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -43,7 +43,7 @@ endef
# 1: package name
define GetABISuffix
-$(call FormatABISuffix,$(1),$(if $(ABIV_$(1)),$(ABIV_$(1)),$(foreach v,$(wildcard $(STAGING_DIR)/pkginfo/$(1).version),$(shell cat $(v)))))
+$(if $(ABIV_$(1)),$(ABIV_$(1)),$(call FormatABISuffix,$(1),$(foreach v,$(wildcard $(STAGING_DIR)/pkginfo/$(1).version),$(shell cat $(v)))))
endef
# 1: package name