summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2024-09-03 14:21:29 -0700
committerRobert Marko <robimarko@gmail.com>2024-09-08 11:49:20 +0200
commitfe6c0796816551b3bac79adf7e4757f7a73559cb (patch)
tree5b500c6e6ab5d785d3fb5cab872d9aa9f0a4155a
parent1fa28dd899593c874da3397efc069e17a66cbfed (diff)
downloadopenwrt-fe6c0796816551b3bac79adf7e4757f7a73559cb.tar.gz
openwrt-fe6c0796816551b3bac79adf7e4757f7a73559cb.tar.bz2
openwrt-fe6c0796816551b3bac79adf7e4757f7a73559cb.zip
uboot-laniq: fix compilation with GCC14
GCC errors on returning int in void function now. Signed-off-by: Rosen Penev <rosenp@gmail.com> Link: https://github.com/openwrt/openwrt/pull/16348 Signed-off-by: Robert Marko <robimarko@gmail.com>
-rw-r--r--package/boot/uboot-lantiq/Makefile2
-rw-r--r--package/boot/uboot-lantiq/patches/0112-MIPS-add-board-support-for-Arcadyan-VGV7510KW22.patch4
-rw-r--r--package/boot/uboot-lantiq/patches/0116-MIPS-add-board-support-for-BT-Home-Hub-5A.patch4
3 files changed, 5 insertions, 5 deletions
diff --git a/package/boot/uboot-lantiq/Makefile b/package/boot/uboot-lantiq/Makefile
index b569232b3d..efee4507e5 100644
--- a/package/boot/uboot-lantiq/Makefile
+++ b/package/boot/uboot-lantiq/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=u-boot
PKG_VERSION:=2013.10
-PKG_RELEASE:=66
+PKG_RELEASE:=67
PKG_HASH:=0d71e62beb952b41ebafb20a7ee4df2f960db64c31b054721ceb79ff14014c55
diff --git a/package/boot/uboot-lantiq/patches/0112-MIPS-add-board-support-for-Arcadyan-VGV7510KW22.patch b/package/boot/uboot-lantiq/patches/0112-MIPS-add-board-support-for-Arcadyan-VGV7510KW22.patch
index 39499fcebc..3f3424da6f 100644
--- a/package/boot/uboot-lantiq/patches/0112-MIPS-add-board-support-for-Arcadyan-VGV7510KW22.patch
+++ b/package/boot/uboot-lantiq/patches/0112-MIPS-add-board-support-for-Arcadyan-VGV7510KW22.patch
@@ -95,7 +95,7 @@
+void show_boot_progress(int arg)
+{
+ if (!do_gpio_init)
-+ return 0;
++ return;
+
+ if (arg >= 0) {
+ /* Success - turn off the red power LED and turn on the green power LED */
@@ -107,7 +107,7 @@
+ gpio_set_value(GPIO_POWER_RED, 0);
+ }
+
-+ return 0;
++ return;
+}
+
+static const struct ltq_eth_port_config eth_port_config[] = {
diff --git a/package/boot/uboot-lantiq/patches/0116-MIPS-add-board-support-for-BT-Home-Hub-5A.patch b/package/boot/uboot-lantiq/patches/0116-MIPS-add-board-support-for-BT-Home-Hub-5A.patch
index fd709bc2ac..992236cded 100644
--- a/package/boot/uboot-lantiq/patches/0116-MIPS-add-board-support-for-BT-Home-Hub-5A.patch
+++ b/package/boot/uboot-lantiq/patches/0116-MIPS-add-board-support-for-BT-Home-Hub-5A.patch
@@ -107,7 +107,7 @@
+void show_boot_progress(int arg)
+{
+ if (!do_gpio_init)
-+ return 0;
++ return;
+
+ if (arg >= 0) {
+ /* Success - turn off the red power LED and turn on the green power LED */
@@ -119,7 +119,7 @@
+ gpio_set_value(GPIO_POWER_RED, 0);
+ }
+
-+ return 0;
++ return;
+}
+
+static const struct ltq_eth_port_config eth_port_config[] = {