summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2022-12-02 20:56:12 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-01-09 21:33:20 +0100
commit2a3283643ccf77b55d67c7a3f96d40576227499c (patch)
tree46678ed84d5d237d81b4a50c86fd1fe3baf09e1e /Makefile
parentd10e6591d1523738852dd0ab625df1f9ea7fc63c (diff)
downloadopenwrt-2a3283643ccf77b55d67c7a3f96d40576227499c.tar.gz
openwrt-2a3283643ccf77b55d67c7a3f96d40576227499c.tar.bz2
openwrt-2a3283643ccf77b55d67c7a3f96d40576227499c.zip
treewide: derive host and hostpkg path from STAGING_DIR
STAGING_DIR may be provided from command line. We currently hardcoded STAGING_DIR_HOST and STAGING_DIR_HOSTPKG to the default location but we currently have some relocatable patch that derive the path from STAGING_DIR. Fix this and correctly derive STAGING_DIR_HOST and STAGING_DIR_HOSTPKG from STAGING_DIR. The intention is to fix inconsistency from the relocatable patch and the use of STAGING_DIR_HOST that is always hardcoded. This with a wrong configuration may end up in broken state with some host tools expecing a PATH from STAGING_DIR and others using library from the default staging_dir/host path. To save downstream project the original implementation is saved while fixing the inconsistency between patch and .mk. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index cbf9fa2cd1..cff0e1d8d4 100644
--- a/Makefile
+++ b/Makefile
@@ -15,7 +15,7 @@ $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt dir
world:
DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep '/usr' -m 1)
-export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
+export PATH:=$(if $(STAGING_DIR),$(abspath $(STAGING_DIR)/../host/bin),$(TOPDIR)/staging_dir/host/bin):$(PATH)
ifneq ($(OPENWRT_BUILD),1)
_SINGLE=export MAKEFLAGS=$(space);